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1 Installing Weintek Built-in CODESYS

Installing Weintek Built-in CODESYS allows users to easily create a cMT+CODESYS
project in CODESYS software. Please find the Package file we prepared and follow
these steps for quick installation.

1. First, get a copy of CODESYS Package file.

gt

weintek_2018012
4 package

2.  Onyour PC, right-click the mouse button and select [Open with CODESYS
Package Manager].

Open with CODESYS Package Manager
Open with...

Share with 2

Restore previous versions
Send to 2

Cut
Copy

Create shertcut
Delete

Rename

Properties

3. Select Complete Setup or Typical Setup (you may select any of these setup

types since the components used by Weintek Built-in CODESYS exist in both

types.)
fJ Installation - Choose Setup Type @
Weintek Built-in CODESYS [2018.1.24]
Please selectthe typeof setup youwould liketo perform. EI

@ Complete setup
All package components will be installed.

) Typical setup
The most commonly used package components will be installed.

4. Click [Next] when seeing the following message.
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& Installation - Setup Completed

Weintek Built-in CODESYS [2018.1.24]

the summary.

The package has been successfully installed. Click Finish to exit the wizard or Mext to see

=l

[d

[ Next > ][ Finish ]

5.  The installed component will be shown in the installation summary.

& Installation - Summary

Weintek Built-in CODESYS [2018.1.24]
Installation summary

Summary:

=l

[d

= Device description (1)

4 m

Component/DeviceDescription/Weintek-Cortex-embedded.devdesc.xml: Iter
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2 Connecting cMT CODESYS

2.1 Connecting Through Network
Connect cMT model’s LAN 1 port with a router or PC.
2. Tap Start button to open HMI system settings window.

3.  Open CODESYS page and find the IP address. By default, DHCP is used and

it will automatically obtain an IP address.

.
| Setting CODESYS
SYSEEM-CR 08 Activation status Activated (QA0000021)

@ Information
CODESYS status start

Application status start

& General Login status logout

Ethernet(LAN1)
(s 1P address 192.168.2.105
® Time/Date Subnet mask 255.255.252.0
Gateway 192.168.1.254

£ HMI Name Mac address 00:0c:26:0f:e3:3b

Version 20180516

2.2 Creating CODESYS Project

1. Launch CODESYS V3.5 and click [File] » [New Project], and then select
[Standard project]. Enter the project name in Name filed, browse for the
location, and then click [OK] to leave.
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=] Mew Project @
Categories: Templates:
{1 Libraries -
: g = =
{_d Projects . I = K=
Empty project  HMI project Standard Standard
project project w...

=
Standard
project w...

Name:

Location:

cMT3090c

C:\Users\user\Documents

A project containing one device, one application, and an empty implementation for PLC_PRG

2. Select Weintek Built-in CODESYS. CODESYS software provides 6 languages

that can be selected in [PLC_PRG in:] drop-down list as shown below.

Structure Text (ST) is used as an example in this manual.

Standard Project

1:

Device:

- Y¥ou are about to create a new standard project. This wizard will create the following
- objects within this project:

- 0ne programmable device as specified below

- A program PLC_PRG in the language specified below
- A cyclic task which calls PLC_PRG

- A reference to the newest version of the Standard library currently installed.

=)

’Weintek Built-in CODESYS (Weintek Labs., Inc.)

PLC_PRG in: |Structured Text (ST)

Continuous Function Chart (CFC)

Continuous Function Chart (CFC) - page-oriented
Function Block Diagram (FED)

Ladder Logic Diagram (LD)

Sequential Function Chart (SFC
Structured Text (ST

3. Double-click on Device (Weintek Built-in CODESYS) to open the settings

window.
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Devices > 7 x
=5 emTane0c [=]
= [ [pevice (weintek Built-n CODESYS) |
=-E PLC Logic

=€} Application

m Library Manager
PLC_PRG (PRG)
= @ Task Configuration

L_| WE!NTEK

= @ MainTask
H PLC_PRG

gi Device X
Communication Settings Scan Network... | Gateway = Device ~
Applications

.
Backup and Restore
Files . % .

Gateway
Log

ateway-1| - VB -
e SRS TP-Address:
localhost

PLC shell

Users and Groups

Task Deployment

Status

Information

Port
1217

4. Open Scan Network tab, CODESYS software will start searching for the

CODESYS devices on the same network. Select the desired device and then

click [OK] to leave. The last two IP address parts (between dots) are

converted into HEX digits and shown in this window. For example, if the IP
address of the CODESYS device is 192.168.2.118, please select HMI

Name[0276].

Select Device

Select the network path to the controller:

= -;10 Gateway-1(scanning...)
cMT-00 [026A]
cMT-8B28-ted [0209]
cMT-DD6A [0241]
cMT-DDAET [023A]
cMT-EGCE [0243]
cMT-E6CA [025E]

EEREERER

Device Name:
Gateway-1

Driver:
TCR/IP

IP-Address:
localhost

Port:
1217

Cancel

5. The project will connect the selected device.
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Gateway
Gateway-1 - [0278] (active) -
IP-Address: Device Name:
|acalhost cMT-E33B
Port Device Address:
1217 0276
Target ID:
16BF 0001
Target Type:
4096
TargetVendor:

Weintek Labs., Inc.

TargetVersion:
3.5.10.30

@ Note

B |P address of the device can be entered in the field shown below.

Gateway
Gateway-1 - 192,168.2.118 -
IP-Address: Press ENTER to set active path...
localhost
Por
1217
6
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3 Creating EasyBuilder Project

*Please use EasyBuilder Pro v6.00.02 build 20180410 or later versions.
3.1 Creating Tags

1. Create several tags in PLC_PRG tab and make tag “test” accumulate

automatically.

M Device PLC_PRG X

1 PROGRAM FLC_FRG

- z VAR
3 read:BOOL;
4 write:BOOL;
5 test:INT;

€ END VAR

1 teatr=test+l;

3.2 Exporting Tag

1. Right-click on Application in Devices tree and then select [Add Object] »
[Symbol Configuration], use defaults.
Add Symbeol Configuration @
B8 Createaremoteaccess symbol configuration.
Name:
Symbal Configuration
[] Include Comments in XML
[[] Support OPC UA Features
Client side data layout
(©) Compatibility Layout
@ Optimized Layout
[ Add ] [ Cancel ]
2. Find PLC_PRG, select the variables to be exported, and then click [Build].
Symbals Access Rights  Maximal Attribute  Type  Members Comment
+ |:| Constants
+ |:| IoConfig_Globals
= PLC_PRG
# read £ " BOOL
# test 4y 4 INT
# write ) ™) BOOL
3.

Select [Build] » [General code], the *.xml file can be found in the directory
of the project.
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3.3 Configuring EasyBuilder
1. Create a project and select Weintek Built-in CODESYS in the device list.

|  Extended Memory |  CelbluwDatNetwork |  Time@ymedDST | eMail | Recipes
Device | Model | Generl | Systemfetting | Remote | Secuity
Dienvice list W hat's mv TP
Mo. Mame Location Address type Inti
= [LocalHMI | Local HMI Local cMT3090 (768 x 1024) -
W Local PLC4  |Weintek Built-in CODESYS Weintek Built-in CODESYS |- |

(2

2. Open Tag Manager and click , and then click [Import Tag] to import

the *.xml file built in preceding steps.

Variable List
Mame : lTagTabIe Find : [0. ]

Verifying Tags with device...

Symbols | Data Description

Import Tags...

Tag

3. The CODESYS tags can now be found in Tag Manager.
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My Application Variable List

- Application Name : ITagTable Find : [Q
[=)-Tags

~-TagTable

Symbols Data Type | Scan Rate (s) | Binary Access

B Tag
Application.P’LC_PRG.rcad BOOL Dcfault gFALSE

- B Application.PLC_PRG.test | INT Default FALSE
Application.PLC_PRG.write BOOL Default EFALSE

Import Status

Imported tag information successfully.
0 warning(s)

4. Create a Numeric object and use “Application.PLC_PRG.test” for address.
After downloading the project to HMI, “test” tag data can be found.
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4 Connecting cMT CODESYS to iR-COP

1. Right-click on Device (Weintek Built-in CODESYS) and then select [Add

Device].

2. Select [CANbus] » [CANbus], and then select [Add Device].

[ Add Device

Name: CAMbus
Action:

@ Append device

(7) Update device

[ et canbus
+ - g EtherCAT
+ - HB Ethernet Adapter

Enter a string for 3 fulltext search in all devices.,.  Vendor: | <Al vendors > v]
Name Vendor Version Description |+
= m Fieldbusses

=~ €AN CAMbus 3

1] 35 - 5mart Software Solutions GmbH

35 - Smart Software Solutions GmbH

Needed for all fieldbusse |
CANbus on a netX device

3.5.10.0
3.5.10.0

< | 1

3. CANbus (CANbus) can be found in Devices tree.

Devices - 0 X
=5 ovTI090c (=]
= m Device (Weintek Built4n CODESYS)
=810 PLC Logic
=1} Application

m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
=g MainTask

[ canbus (CaNbus)

& pic PRG

4. Double-click on CANbus (CANbus) with the current window opened in
Devices tree, or right-click on CANbus (CANbus) and then select [Add

Device].

5. Click [Fieldbusses] » [CANopen] » [CANopen Manager] » [CANopen
Manager], and then select [Add Device].

(1] Add Device |
Name: CANopen_Manager
Action:
@ Append device (7) Insert device () Update device
Enter a string for & fulltext search in all devices...  Vendor: | <all vendors: -
Mame Vendar Version Dyl =
= m Fieldbusses
= Cifl CANopen £
=--€ifl CANopenManager
m |CANopen_Manager 35 - Smart Software Solutions GmbH 3.5.10.0 CA
m CAMopen_Manager_FDT 35 - Smart Software Solutions GmbH 3.5.7.20 c
ﬁi CAMopen_Manager_SIL2 35 - Smart Software Solutions GrbH 3.5.10.0 ce_
fesel | - - . .
] 1 | 3

10
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Double-click on CANopen_Manager with the current window opened in

Devices tree or right-click on CANopen_Manager and then click [Add

Device].

7.  Click [Fieldbusses] » [CANopen] » [Remote Device], find iR-COP and then

select [Add Device].

[ Add Device [==3a]
Name: iR_COP

Action:

@ Append device () Insert device () Update device

Enter a string for a fulltext search in all devices... ~ Vendor: | Weintek Labs., Inc. hd
Marme Vendor Wersion Descriptic
= ﬂj Fieldbusses

= - &If CAMopen
=€l Remote Device
m iR-COP Weintek Labs., Inc. Revision=16%00000001, FileVersion=1.1 Imported f

< | 1 k

8.  Under [iR-COP] select [Miscellaneous], add I/O module and then select
[Add Device].
[ Add Device ®
Name: |iR_COP_1
Action:
(®) Append device () Insert device (0) Update device
|Enter a string for a fulltext search in all devices. .. | Vendor: | <Al vendors> v

Mame Vendor Version Description

= ﬂ'i Miscellaneous
ﬂi R-AID4-TR Weintek Labs., Inc, Revision=16#00000003, FileVersion=1.4 CAMNopen-Module
ﬂi iR-AIO4-YT Weintek Labs., Inc, Revision=16#00000003, FileVersion=1.4 CAMopen-Module
m iR-AMOA-YT Weintek Labs., Inc. Revision=16=00000003, FileVersion=1.4 CAMNopen-Module
ﬂi iR-AQ04-VI Weintek Labs., Inc. Revision=16#00000003, FileVersion=1.4 CANopen-Module
ﬂi R-DI16+4 Weintek Labs., Inc. Revision=16#00000003, FileVersion=1.4 CANopen-Module
ﬂi iR-DM16-M Weintek Labs., Inc, Revision=16#00000003, FileVersion=1.4 CAMNopen-Module
ﬂi iR-DM16-F Weintek Labs., Inc., Revision=16#00000003, FileVersion=1.4 CAMNopen-Module
m iR-DQ016-M Weintek Labs., Inc. Revision=16#00000003, FileVersion=1.4 CANopen-Module
ﬂ'i iR-DQO16P Weintek Labs., Inc. Revision=16#00000003, FileVersion=1.4 CAMNopen-Module
ﬂi R-DQOER Weintek Labs., Inc, Revision=16#00000003, FileVersion=1.4 CAMNopen-Module
ﬂi PUD1-Axis O Weintek Labs., Inc, Revision=16200000003, FileVersion=1.4 CAMNopen-Module
m PUD1-Axis 1 Weintek Labs., Inc. Revision=16=00000003, FileVersion=1.4 CAMNopen-Module
ﬂi PUO1-Axis 2 Weintek Labs., Inc. Revision=16#00000003, FileVersion=1.4 CANopen-Module
ﬂi PUD1-Axis 3 Weintek Labs., Inc. Revision=16#00000003, FileVersion=1.4 CANopen-Module

9. Double click on CANbus (CANbus) in Devices tree to open the settings

window. Please select the correct baud rate for iR-COP in General tab.

11
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® cMT3090c.project - CODESYS

Eile Edit ¥ew Project Buld Online Debug Tools Window Help

S =11} %18 (T 08
Devices ~ 3 X [ m_omis N
=g T a0see =
= [ Device (weintek Buitin CODESYS) General
= @ﬂ PLC Logic

=i} Application
m Library Manager
BH pLc_PRG (RG)
= @ Task Configuration
= @ MairTask
&) pLc_PRG
=- [ cANbus (CANbus)
=[] CANopen_Manager (CANopen_Manager)
=-[{ ®_cop (r-coP)
[ R_DM15_N R-DM16-M)

CANbus Parameters

CANbus /O Mapping

Status

Information

2 Devices |[[) PoUs

%

[ canbus x

General

Network:

Baudrate (bit/s):

]

10. Create CANopen variables in PLC_PRG, for example:

FROGRAM PLC _FRG

p VAR

3 x0 : BOOL;
4 x1 : BOOL;
& END VAR

L_| WE!NTEK

CAN

250000 “

11. Double click on iR_Cop in Devices tree to open the settings window. Select

related variables in CANopen I/0 Mapping tab.

General Find Filter Show all - |
T Variable Mapping  Channel Address Type Unit Description i
=" DO byte 1 %QB0 USINT L
SD0s "% Application.PLC_PRG.x0 k] BitD %oMe-5  BOOL [
" Application.PLC_PRG.x1 " Bit1 OKGL EOOL MW
CANopen If0 Mapping K@ Bit2 X0, 2 BOOL
% Bit3 %0XD. 3 BOOL
Status ] Bit4 QX0 4 BOOL
"% BitS %QXD. 5 BOOL
Information " Bit6 %QXD.6 BOOL
"% Bit7 %QX0.7  BOOL
+-Tig DO byte 2 %GB1 USINT
+-Tg DO byte 3 QB2 USINT il
.

12. When finished, click [Online] » [Login] to download the project to

CODESYS.

12
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5 Connecting cMT CODESYS to iR-ETN

1. Right-click on Device (Weintek Built-in CODESYS/cMT-CTRL) and then select

[Add Device].
2. Select [Ethernet Adapter] » [Ethernet] and then click [Add Device].

[ Add Device (=3

Mame: Ethernet
Action:

@ Append device () Update device

Enter a string for & fulltext search in all devices...  Vendor: | <Al vendorss> v]

Mame Vendor Version Description

= m Fieldbusses
+- AN CANbus
+- pah EtherCAT
= - BB Ethernet Adapter
m Ethernet 35 - Smart Software Solutions GmbH 3.5.10.0 Ethernet Link.

+- = EtherNet/TP il

3. Ethernet (Ethernet) can be found in Devices tree.

Devices - 0 X
=5 MTI0%0 RETN (=]
= ﬁ |Device {Weintek Builtin CODESYS)
=& PLC Logic

=L} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
= @ MainTask
B pLC PRG
[ Ethernet (Ethernet)

4. Double-click on Ethernet with the current window opened in Devices tree
or right-click on Ethernet and then select [Add Device].

5. Click [Fieldbusses] » [Modbus] » [Modbus TCP Master] » [Modbus TCP
Master], and then select [Add Device].

[ Add Device [==3a]
Name: Modbus_TCP_Master
Action:
@ Appenddevice () Insert device (7) Update device
Enter a string for a fulltext searchin all devices... | Vendor: | <Al vendors:> -
Mame WVender Wersion Description *

= ﬂj Fieldbusses
+ - = EtherMet/IP
=/ Wil Modbus
= Wil Modbus TCP Master

m Modbus TCP Master 35 - Smart Software Solutions GmbH 3.5.10.0 A device thal—

+ - Wl ModbusTCP Slave Device i

m

6. Double-click on Modbus TCP Master with the current window opened in
Devices tree or right-click on Modbus TCP Master and then click [Add

13
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Device].
7.  Click [Fieldbusses] » [Modbus] » [Modbus TCP Slave] » [Modbus TCP Slave],
and then select [Add Device].

Add Device

Name: Modbus_TCP_Slave
Action:

@ Append device () Insert device Flug device @) Update device

Enter a string for & fulltext search in all devices...  Vendor: | <all vendors=> -
MName Vendor Version Description
'ﬂi Fieldbusses

= . Wi Modbus
= ¥ls Modbus TCP Slave
i 35 - Smart Software Solutions GmbH ~ 3.5.10.0 A generic Modbus ¢

8. Double click on Ethernet in the Devices tree, enter CODESYS’s IP address in
General tab, and then select [Change Operating System Settings].

[f Device /m Ethernet x}/ﬁ Modbus_TCP_Master ] o
=) oMTI090_RETN
= m Device (Weintek Builtin CODESYS) General
_El] PLC Logic Interface: eth0 E]
‘O Application Status

; ) (7) Use Operating System Settings
m Library Manager -

FLC_FRG (FRG) Ethernet Device I/0 Mapping @ Change Operating System Settings

‘@ Task Configuration : )
=¥ MainTask Information IP Address 192 . 188 . 2 . 1%
@ PLC_PRG — Subnet Mask 255 . 255 . 252 . 0

- () [Ehemet Ehemen
= m Modbus_TCP_Master (Modbus TCP Mastg

----- m Modbus_TCP_Slave (Modbus TCP Slg

| Default Gateway 192 . 168 . 1 . 254

m | 3

4
22 Devices | Modules

9.  When CODESYS is already connected, go to General tab and click the [...]
button near Interface field and select ethO.

Metwork Adapters E

Interfaces:

Wame Diescription IP Address

Io 127.001

vinetl 10.2552552
TP Address 192 168 . 2 . 73
Subnet Mask 255 355 252 . 0

Diefanlt Gateway 192 188 . 1 254
MAC hddress 00.0C:26:.0FE3 3B

[ ok ][ Comeel |

10. Select Modbus_TCP_Slave in the Devices tree and then go to General tab
to set up IR-ETN’s IP address and Unit ID.
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[# Modbus_TCP_Slave x

=5 oMT3090_R-ETV
= m Device (Weintek Builtsn CODESYS)
=Bl PLC Logic
=L} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
=-g8 MainTask
& pLC_PRG
= m Ethernet (Ethernet)
= m Modbus_TCP_Master (Modbus TCP Maste

General

Modbus Slave Channel

Modbus Slave Init

ModbusTCPSlave Parameters

ModbusTCPSlave If0 Mapping

Status

m |Modbus_TCP_SIave (Modbus TCP Sla

Information

4| i b

22 Devices | ® Modules

L_| WE!NTEK

Modbus-TCP
Slave IP Address: 192 . 168 . 2 144
Unit-ID [1..247] 1
Response Timeout (ms) 1000
Port 502
] T v

11. Open [Modbus Slave Channel] tab and create Modbus Variable.

ModbusChannel

Channel
Name

Access Type
Trigger
Comment
READ Register
Offsat

Length

Error Handling

WRITE Register
Offset

Length

Read 0x-0

=l

[Read Discrete Inputs (Function Code 2)

[Cydic

0x0000

1

Keep last Value

0x0000

0

v] Cycle Time (ms)

100

oK

J

Cancel ]

ModbusChannel

Channel
Name

Access Type
Trigger
Comment
READ Register
Offsat

Length

Error Handling

WRITE Register
Offset

Length

Write Ox-0

[Wrihe Multiple Coils (Function Code 15)

[Cydic

1

Keep last Value

v] Cycle Time (ms)

100

oK

J |

Cancel ]

12. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write
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a command as shown below.

FROGRAM FLC _FRG
VAR
read :BOOL;
write:BOOL;
END VAR

[T N T T % T ]

(=4}

write:=1;

[L*

13. Open Modbus_TCP_Slave in Devices tree and then go to
[Modbus_TCPSlave 1/0 Mapping] tab to set variable mapping.

Variable Mapping  Channel Address Type Unit Description
=t Read 0x-0 %%IBO ARRAY [0..0] OF BYTE Read Discrete Inputs
= Read 0x-0[0] 2RIB0 BYTE Read Discrete Inputs
“p Application.PLC_PRG.read ] Eitd Behe-o BOOL 0x0000
=T Write 0x-0 %QB0 ARRAY [0..0] OF BYTE Write Multiple Coils
=T Write Ox-0[0] QB0 BYTE Write Multiple Coils
"% Application.PLC_PRG.write " Bitd SLEWE:8  BOOL 0x0000

14. When finished, click [Online] » [Login] to download the project to
CODESYS.
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6 Connecting cMT CODESYS to iR-ECAT

1. Right-click on Device (Weintek Built-in CODESYS/cMT-CTRL) and then select

[Add Device].

2. Select [EtherCAT] » [Master] » [EtherCAT Master] and then click [Add

Device].

[ Add Device

Mame: |Eﬁ'|erCAT_Master

Action:
(®) Append device

(C) Update device

|Enter a string for a fulltext search in all devices. .. | Vendor: | <Al vendors> ~

Name
+ m Miscellaneous
= ﬂj Fieldbusses
+-- AN CANbus
= poi EtherCAT
= nﬁ Master

ﬂi CHxxx internal EtherCAT Master

Vendor Version 2

[ [EthercAT Master

[ EthercaT Master
[0 EthercaT Master
[ EthercaT Master
[0 EthercaT Master
[ EthercaT Master
[0 EthercaT Master
ﬂi EtherCAT Master SoftMation

35 - Smart Software Solutions GmbH 3.5.12.60
35 - Smart Software Solutions GmbH 3.5.10.0
35 - Smart Software Solutions GmbH 3.5.12.0
35 - Smart Software Solutions GmbH 3.5.12.60
35 - Smart Software Solutions GmbH 3.5.13.0
35 - Smart Software Solutions GmbH 3.5.14.20
35 - Smart Software Solutions GmbH 3.5.15.0
35 - Smart Software Solutions GmbH 3.5.15.30
35 - Smart Software Solutions GmbH 3.5.10.0

3. EtherCAT_Master can be found in Devices tree.

Devices

~ 0 X

=5 Add EtherCAT

= [ [pevice (cMT-CTRL)

=&l pLC Logic

=1L} Application
ﬁ] Library Manager
W] PLC_PRG (PRG)
= @ Task Configuration
=58 MairTask
] EtherCAT Master EtherCAT Task
& PLC_PRG

iBus (iBus)
[l EtherCAT Master (EtherCAT Master) |
—

4. Double-click on EtherCAT _Master with the current window opened or in

Devices tree right-click on EtherCAT _Master and then select [Add Device].
5. Click [Fieldbusses] » [EtherCAT] » [Slave] » [iR-ECAT], and then select [Add

Device].
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Marme

+
+
i

oy

= ﬁ Fieldbusses
=/ ol EtherCAT
= ﬁslave

[ Delta Electronics, Inc. - Serve Drives
[ Festo Electric-Drive
[ Hitachi Industrial Equipment Systems Co. Ltd. - Serve Drives
[l ifm electronic - ifm electronic EtherCAT Devices
| Panasonic Corparation, Appliances Company - AC Servo Driver
| Parker Hannifin - Parker Servo Drive 1M
[ Parker Hannifin - Parker Servo Drive 15
[ schneider Electric - Drives
| Servo Drives
[l St&ubli Robotics - Drives
| STOEBER. ANTRIEBSTECHMIK GmbH Co. KG - Antriebe
| Weintek Labs., Inc. - Coupler
[ recar

[ [rEcar

6. Double-click on iR-ECAT in Devices tree with the current window opened or
right-click on iR-ECAT and then click [Add Device].
7.  Click [Fieldbusses] » [EtherCAT] » [Module], and then select [Add Device].

MName Vendor
= ﬁ Fieldbusses
=/ polh EtherCAT
= I}E Module

ﬁ R-AID4-TR Weintek Labs., Inc
ﬁ iR-AIO4-VI Weintek Labs., Inc
m R-AMOG-YT Weintek Labs., Inc.
m R-AQO4-VI Weintek Labs., Inc.
m R-DI16-K Weintek Labs., Inc.
m Weintek Labs., Inc
m R-DM16-F Weintek Labs., Inc
ﬁ R-DQOS-R Weintek Labs., Inc
ﬁ R-DQ 16N Weintek Labs., Inc
m R-DQ16-P Weintek Labs., Inc.
m R-PUDL-P Axis O Weintek Labs., Inc.
m R-PUDL-P Axis 1 Weintek Labs., Inc.
m R-PUD1-P Axis 2 Weintek Labs., Inc
m R-PUDL-P Axis 3 Weintek Labs., Inc

Wersion

o o o o o o o o o o o o o O

8. Double click on EtherCAT in the Devices tree, click Browse in General tab,
and then select [ethO0].

Devices

~ 2 x () EthercAT_Master x [[if] Device

=[5 Add EthercAT

= [ Device (MT-CTRL) | General [ Autoconfig Master/Slaves EtherCAT_“'
=10 PLc Logic
= €} Application RSl e EtherCAT NIC Setting
:\iﬂgﬁfpvRZa;:{Q;)f EtherCAT /0 Mapping Destination Address(MAC) FF-FF-FF-FF-FF-FF Broadcast [ Enable Redundancy
= Task Configuration status Source Address {MAC) 00-00-00-00-00-00
=& MainTask Network Name
&) EtherCAT_Master EtherCAT Task Information

8] pLc_rre

(T Bus (Bus)

=[] EtherCAT Master (EtherCAT Master)
= [ R_ECAT (R-ECAT)
[ R_DM16 N (RDM154)

(® Select Network by MAC

O Select Netwark by Name

Select Network Adapter

000C261899E7

000C26113234  vnetl

MAC address Name  Description

9. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write

a command as shown below.
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[1}]

R

FROGRAM FLC _FRG
VAR
read :BOOL;
write:BOOL;
END VAR

write:=1;

L_| WE!NTEK

10. In Devices tree open iR-ECAT » [EtherCAT I/O Mapping] and configure the

settings.

Variable Mapping  Channel Address Type Unit Description

=-"g iR_DM15_N Digital Qutput %QB0 BYTE iR_DM16_M Digital Output
"% Application,PLC_PRG.read g BitD 2OND-D BOOL
"% Bit1 %Q¥0.1  BOOL
"% Bit2 %Q¥D.2  BODL
" Bit3 %QX0.3  BOOL
" Bit4 %Q¥0.4  BOOL
"9 Bit5 %Q¥0.5  BOOL
] Bit6 %QKD.6  BOOL
"% Bit7 %Q¥0.7  BOOL

= iR_DM15_N Digital Input %IB2 BYTE iR_DM16_N Digital Input
*p Application.PLC_PRG.write ] Bit0 SoRE S BOOL
“ Bit1 %IX2.1 BOOL
3 Bit2 %IX2.2 BOOL
E Bit3 %IX2.3 BOOL
E Bit4 %IX2.4 BOOL
* Bit5 %INZ.5 BOOL
* Bits %IX2.6 BOOL
* Bit7 %INZ.7 BOOL

11. When finished, click [Online] » [Login] to download the project to

CODESYS.
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1.
2.

cMT-CTRLO1 Quick Start

Right-click on iBus and select [Add Device].

Select [Miscellaneous], add the iR modules connected to cMT-CTRLO1, and

click [Add Device].

L_| WE!NTEK

Devices > B x FLC_FRG @ iR 9 pdderce x
=) Add CTRL = 1 : [N
J,] @ Device (@T<TRL) Madule Parameters Name:
=80 pLC Logic y Wil
%0 Application Module /0 Mapping (® Append device © Update device
(i) Library Manager 1
] sic prc pre) Status Enter a string for a fulttext search in al devices. ., \ Vendor: | <Allvendors> %
=& Task Configuration N — Name Vendor Version  Description
= mainTask = [ Miscellaneous
& pLc_pre ([ R-AID4TR  Wenteklabs. Inc.  L0.0.0  4x Temperature Input , RTD /Thermocouple, Consul
=" [ Bus (Bus) (@ rearo+n WeintekLabs., Inc.  1.0.0.0 4 analog Input , 16 bit, £10V + £20mA ~ 1-5V ~ 4|
(@ »_oms N (RoM1E-1) ([ R-aMOSVT  WenntekLabs, Inc.  10.0.0  Anolog,4 x Input 16bit , 2 x Output 12bit, £10V +
(@ RAQUHT  Wenteklebs,Inc.  L0.LO 4 xanabogoutput, 12bit, 10V~ £20mA - 15V ~
(H reorsx WeintekLabs., Inc. ~ 1.0.0.0 16 Points Digital Input, Consumption (SV)-83mA/0.41 | §;
(@ ROMIEN  Wennteklabs, Inc.  1.0.0.0 8 Points Digital Input, Points Sink Type Digital Outp
(H ROMIEP  Wenteklebs., Inc.  10.0.0 8 PointsDigital Input,§ Points Source Type Digital O
(@ rDQueR  Wenteklabs, Inc.  10.0.0 8 PointsRelay Output, Consumption (5V}-220mA/1.1
(@ RDQi6N  Wenteklabs, Inc.  L0.0.0 16 Points Sk Type Digital Output,
(@ rDQi6P  Wenteklobs, Inc.  10.0.0 16 Points Source Type Digital Output, Consumption(
(H rpuo1e WeintekLabs,, Inc. ~ 1.0.1.0  1-Axis Motion Controller(PA/PB), 1-Encoder (A/B/2),

3. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write

a command as shown below.

1 FROGERAM FLC_FRG

Zz VAR

2 read :BOOL;
4 write:BOOL;
5 END VAR

. —

1 write:=1;

2

4. In Devices tree open iR module list » [Module I/O Mapping] tab and

configure the settings.

Module Parameters Find Filter Show all -
| Module 1O Mapping Variable Mapping  Channel  Address Unit  Description
=t IND %182 24Vde Source/Sink Input
Status 4 application.PLC_PRG.read " Lo
bl Ix2.1
Information 5 %IX2.2
k] %IN2.3
b %INZ.4
» HIN2.5
bl BIX2.6
b IN2.7
- "y %QB0 24Vde Sink Output
" Application.PLC_PRG.write % 5%GX3-6  BOOL
i 2LOXD. 1 BOOL
" %QX0.2  BOOL
i %LOX0.3 BOOL
"# %QX0.4  BOOL
" wOX0.5  BOOL
i %LOXD.6 BOOL
"% %QX0.7  BOOL

5. When finished, click [Online] » [Login] to download the project to

CODESYS.
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8 CODESYS Ethernet/IP Scanner Quick Start

CODESYS limitation: Currently, only the Ethernet/IP Scanner in CODESYS version

3.5.15 is supported. Using other versions may result in compilation failures.

1. Right-click on Device (Weintek Built-in CODESYS/cMT-CTRL) and then select
[Add Device].
2. Select [Ethernet Adapter] » [Ethernet] and then click [Add Device].

[ Add Device X

| MName Ethermet_1

Action

© Append device () Update device
String for a full text search Vendor <Al vendorss e
Name Vendeor Version Description
= m Fieldbuses
+ - CAN CANbus
+-poks EtherCAT
= - BB Ethernet Adapter
ﬂi Ethernet 35 - Smart Software Solutions GmbH 3.5.10.0 Ethernet Link.
ﬂi 35 - Smart Software Solutions GmbH 3.5.15.0 Ethernet Link.
m Ethernet 35 - Smart Software Solutions GmbH 3.5.16.0 Ethernet Link.
[ Ethernet 35 - Smart Software Solutions GmbH 3.5.17.0 Ethernet Link.
@ Group by category (@ Display all versions (for experts only) ("] Display outdated versions

3. Ethernet (Ethernet) can be found in Devices tree.

Devices ~ I X
=iz EthernetP -
= m Device (Weintek Built-n CODESYS)
=&l PLC Logic

=1L} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
= @ MairTask
& PLC_PRG
m Ethernet (Ethernet)

4. With the current window opened, double-click on [Ethernet] in Devices
tree or right-click on [Ethernet] in Devices tree and then select [Add
Device].

5.  Click [Fieldbuses] » [Ethernet/IP] » [Ethernet/IP Scanner] » [Ethernet/IP
Scanner], and then select [Add Device].

21

JoKyMeHT npefocTaBsieH KoMnaHuen "PycasTomaTuka". WWW.RUSAVTOMATIKA.COM


https://www.rusavtomatika.com/?utm=documents

cMT+CODESYS and Remote I/O Quick Start Guide I__| WE'NTEK

| Name EtherMet_IP_Scanner

Action

() Append device () Insert device 0 Updatedevice ] Update same devices in project

String for & full text search Vendor <Al vendors> ~
Mame Vendor Version Description
= ﬂ'i Fieldbuses

= - == EtherMNet/IP
+ - = EtherNetIP Local Adapter
=~ = EtherMet/IP Scanner
ﬂi EtherMet/IP Scanner 35 - Smart Software Solutions GmbH 3.5.10,30 EtherMNet/TP 5
ﬂi EtherMet/IF Scanner | 35 - Smart Software Solutions GmbH | 3.5.15.20 EtherMet/TF &
-7

6. With the current window opened, double-click on [EtherNet/IP Scanner] in
Devices tree or right-click on [EtherNet/IP Scanner] in Devices tree and
then select [Add Device].

7.  Click [Fieldbuses] » [EtherNet/IP] » [EtherNet/IP Remote Adapter] »
[iR-ETN], and then select [Add Device].

For more information about how to generate and add iR-ETN.eds file,
please see chapters 1 and 2 in iR-ETN EtherNet/IP Connection Guide.

| Name R_ETM
Action
() Insert device © Updatedevice (] Updatesame devices in project
String for a full text search Vendor <Al vendors: w
Mame Vendor Version
= m Fieldbuses
= == EtherMet/IP
= == EtherMNet/IP Remote Adapter
ﬂi i\, EtherMetlP Adapter 35 - Smart Software Solutions GmbH Major Revision=16#%1, M
ﬂi Generic EtherMet/IP device 35 - Smart Software Solutions GmbH 4.1.0.0
Eﬂ iR-ETM Weintek Labs., Inc. Major Revision=16%1, M

8. When CODESYS is already connected, go to General tab and click the
[Browse...] button near Interface field and select ethO.

Network Adapters @I
Interfaces:

Name Description IP Address

lo 127001

vnetl 10.255.2552
IF Address 192 168 . 2 . 73
Subnet Mask 255 255 352 . 0

Defanlt Gateway 192 . 1e8 . 1 254
MAC Address 00:0C26:0FE3:3E

[ ok [ cCaneel |

9. Select iR-ETN in Devices tree and then go to General tab to set up IR-ETN’s
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IP address.

Devices > 1 X g8  ENIPScannerServiceTask [ Ethernet [ Device EF iR_ETN x| EtherNet IP_Scanner
=3 Ethernetip -
=- [ Device (Weintek Builtin CODESYS) General Address Settings
=Bl PLC Logic i
Y Connections IPaddress | 192 . 168 . 3 . 21 d
=0
O Appiication Etheri\'et/IP

Library Manager
PLC_PRG (PRG)
= (&8 Task Configuration
=& ENIPScanner]QTask _
8 Etherlet_IP_Scanner.10Cyd | | Log (0 Compatibility check
=g ENIPScamnerServiceTask

Assemblies

User-Defined Parameters Electronic Keying

8] EtherNet_IP_Scanner.Serviq | | EtherNet/IP /O Mapping Vendor ID 156 [ Chedcmatch
=g MainTask Devicetype 12 @ Check match
PLC_PRG EtherNet/IP [EC Objects
B P Product code 1794 @ check match
= [ Ethemet (Ethernet) ==
= Status . N

[ Etheriet_IP_Scanner (EtherNet/IP Scar Majorrevision 1 @ Check match

£ r_emi grem) . Minorrevision 1 () Check match

10. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write
a command as shown below.
1| PROGRAM PLC_PRG

2 VAR

2] read:BOAL;
4 write:bool;
5 END VAR

'_I Weite:=TE

11. In Devices tree open iR_ETN » [Ethernet/IP I/O Mapping] tab and configure

the settings.
Variable Mapping  Channel Address Type Unit  Description
=-[_dl Exlusive Owner

E | slot 1 DM16-N DI %eIB0 BYTE Mew Help String
*p Application.PLC_PRG.read "% Eit0 LIRS BOOL
H Eit1 %eIX0.1 BOOL
H Bit2 %elX0.2 BOOL
R Eit3 %IX0.3 BOOL
i Bit4 %alX0.4 BOOL
k] Bits %aIX0.5 BOOL
i/ Bit6 %IX0.6 BOOL
k] Bit7 %RIN0.7 BOOL

+ 4 slot 20M16-P DI %IB1 BYTE MNew Help String

=iy slot 1DM16-M DO %L0B0 BYTE MNew Help String
"% application,PLC_PRG.write T Bitd S4ONE-0 BOOL
" Bit1 Q0. 1 BOOL
" Bit2 QX0 2 BOOL
" Bit3 Q0. 3 BOOL
" Bit4 QXD 4 BOOL
" Bit5 %0X0.5 BOOL
"% Bit6 %QX0.6 BOOL
] Bit7 %OX0.7 BOCL

+- T slot 2DM16P DO %QB1 BYTE MNew Help String

12. When finished, click [Online] » [Login] to download the project to
CODESYS.
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9 Starting iR Analog Modules

9.1 Analog Module Wiring

I__“v WE!NTEK

Please see UM018013E iR-Axxx-VI _UserManual eng.pdf for information on wiring

when using iR-Al04-VI,iR-AMO06-VI,iR-AQ04-VI modules.

Please see UM018014E iR-Axxx-TR _UserManual eng.pdf for information on wiring

when using iR-Al04-TR module.

9.2 Setting Analog Channels
9.2.1 Using EasyRemotelO to Set Channels (iR-ETN)
1. Search for iR-ETN on the network.

Eﬂﬂl EasyRemotelO
File Edit View Online Tools Help
EEBR o B PRI Os [ @ @ ©9 °8

Project Window A X z
10/ Modules Address Map Parameter Power Information

v B} iR-ETN (192.168.1.37)

il #1: iR-AQ04-VI Channel Hame Type Onling Valne Pmject Value
i =2 iR-AI4-vI ~ iR-ETN (182.168.1.37)
il #3:iR-AI04-TR #1: iR-AQ04-VI AO
#2: iR-AID4-VI Al
#3: iR-AI04-TR Al
2. Open the parameter tab of the module to be set.
File Edit View Online Tools Help
& 8 B R = M BB 02 He [@R Ne @ °9 °Q
Encier oy Al IO Modules Address Map Power Information
M EI- #1; iR-AQDM-VI ] Channel Name Modbus Mapping  Online ¥alue  Project Valve
EzA= e v #1:iR-AQD-VI
il #3iR-AI04-TR Product Code 0x7530
Firmware Revision %7331
Hardware Revision (7532
Power Consumption 07533
Point of Digital Input (7356
Point of Digital Output 07357
3. Enter the parameters as shown below.
Channel Name Modbuz Mapping  Online ¥alve  Project Value
Analog Qutput Error Mode #3 [1815(3] Keep last value
Analog Output Error Value #0 1819 0
Analog Output Error Value #1 Ox181a 0
Analog Output Error Value #2 0181k 0
Analog Qutput Error Value #3 Ox181c 0

Output Mode #0

Output Mode #1 (rede
Output Mode #2 (reded2
Output Mode #3 (xdel

Output Scale Range Upper Limit 20 (ededd
Output Scale Range Upper Limit 1 (weded3
Output Scale Range Upper Limit #2 (ed e
Output Scale Range Upper Limit #3 (eded7

4. Download the project to finish setting parameters.
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File Edit View Online Tools Help

H BB F 0 B R e @R D iR °° g

e Uit 2 H 10/ Modules ' Parameter Power Information
~ B} iR-ETN (192.168.1.37)
EI #1: iR-AQ4-VI Channel Name Modbus Mapping  Ounline Value  Project Value
B #2iR-Al04-VI Point of Digital Qutput 07557 0
Bl #3:iR-AI4-TR Number of Analog Input 7558 0
Number of Analog Output 07559 4
Analog Qutput Error Mode 20 0:1815[0] Errorvalue  Error value
Analog Output Error Mode #1 0x1815[1] Errorvalue  Error value
Analog Output Error Mode #2 0x1815[2] Errorvalue  Errorvalue
Analog Output Error Mode £3 0x1815[3] Errorvalue  Errorvalue
Analog Output Error Value #0 1819 0 0
Analog Output Error Value #1 1812 0 0
Analog Output Error Value #2 D181k 0 0
Analog Output Error Value #3 0x181c o o
Qutput Mode 20 Duede20 1-5V 1-5% <
Output Mode #1 Duede21 =10V +10v -
Output Mode #2 Dide22 =10V 10V 4
Output Mode #3 Oxde23 =10V 107 4
9.2.2 Using CODESYS to Set Channels (iR-ETN)
1. AddiR-ETN in CODESYS according to the wiring diagram.
2. [Modbus_TCP_Slave] » [Modbus Slave Init] » [New]
Devices ~ B X Modbus_TCP_Slave x -
=31 ETN_AIO_Contig -
= f Devi (Weintek Buit-n CoDESYS) General Line  Access Type WRITE Offset DefaultValue  Length  Commen t
Modbus Slave Channel
Modbus Slave Init
ModbusTCPSiave Parameters
ModbusTCPSiave /0 Mapping
= [ Ethernet Ethernet)
= [ Modbus_TCP_Master (Madbus TCP Master) Status
[ [Modbus_TCP_Slave (Modbus TCP Slave)
32 Devices B vodues rfematen
PoLs v 2 x
=5 ETN_AIO_Config hd
B Project settings
< >
Wove up Move d New. Delet Edit.

Initialization Value it
Access Type Write Multiple Registers (Function Code 15) v
RegisterOffset |zunn|:|| w |

Initialization Value

Comment |iR-El'N Modulel, parameter 1

Cance

Find iR-ETN Modbus Address Mapping table in these user manuals:
For analog modules see UMQ18013E iR-Axxx-VI UserManual eng.pdf

For temperature module see UM018014E iR-Axxx-TR_UserManual eng.pdf

3. When finished, click [Online] » [Login] to download the project to
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CODESYS.

Exporting PLCopenXML from EasyRemotelO:

1.
2.

Open EasyRemotelO » [File] » [Export PLCopen XML].
Select Modbus_TCP_Master device, open Project tab » [Import
PLCopenXML File].

NTEK

Fle Edt View Project Buld Online Debug Tools

Window  Help

e H &S L= O i | o X =
]
Devices > x [ Modbus TCP _Slave [ iR_ETN_192 168 1 37 X -~
= Bl PicLoge vl
=€) Application General Line  Access Type WRITE Offset DefaultValue  Length  Commer A
il Liorary Manager Modbos Save Chamnel 1 Wiite Single Register (Function Code 08)  16#0x17d4 (=6100) 0 1
PLC_PRG (PRG) ochus Save Hhemne 2 Write Single Register (Function Code 06)  16#0x273d (-10045) 0 1
= @ .
) Task Configuration A # -
] o odbus Savetnt 3 Wite Singk Register (Functon Code 06) 162000 (<1200} 0 i
= & ManTask 4 Wite Single Register {Function Code 06)  16#0x4e20 (=20000) 17 1
&) picpro T m— 5 Write Single Register (Function Code 06)  160x4e21 (<2000 1 1
= [ Ethernet Ethernet) 3 \Write Single Register (Function Code 05)  16#0x4e22 (=20003) 0 1
= (i Modbus_TCP_Master (Modbus TCP Master) ModbusTePSlave /O Mapping 7 \Write Single Register (Function Code 05)  16#0x4e23 (=20003) 0 1
[ Modbus_TCP_slave (Modbus TCP Slave) 8 WWrite Single Register (Function Code 08)  16#0x4e24 (=20004) 32000 1
(@ R_E™_192_165_137_(Modbus TP slave) || | status 9 Write Single Register (Function Code 06)  16#0x4e25 (=20005) 32000 1
< > 0 write Sngle Register (Functon Code 05)  16+0x4e25 (=20005) 32000 1
. Information A # =
52 vevices | B vodues 11 write Sngle Register (Functon Code 0)  1650x4e27 (=20007) 32000 1
12 write Sngle Register (Functon Code 05)  16#0x4e78 (=20008) 33536 1
POUs - 2x 13 write SngeRegister (Functon Code 08)  1630x4e79 (=20009) 33536 1
=31 Em_ara confiy - 14 write Single Register (Function Code 08) 2 (-20010) 33536 1
B project settings 15 Write Single Register (Function Code 08) dedb (=20011) 33536 1
16 Write Single Register (Function Code 06)  160xe2c (=20012) 5 1
17 Wiite Sinde Redister (Function Code 06)  16#0x4e2d (=20013) 5 1 v
< >
Move up Vove down New. Delete.. Edt..

Parameter settings in EasyRemotelO will be imported to CODESYS, and the

parameters are written to the module after login.

9.2.3 Using CODESYS to Set Channels (iR-COP)

1.
2.

Add iR-COP following the steps explained in Chapter 4 in this manual.
[iR_COP] » [SDOs] » [Add SDO]

Devices - R X [ R_cop x
=[5 COP_AIO Config hd
=/ (i) Device (Weintek Built-n CODESYS) General ok AddSDO [ Edit X Delete Move Up # Move Down
=Bl pLc Logic Line  IndexSubindex  Name Value  Bitlength  Comment
y . PDOS
= £} Application
Library M
i) Library Manager o0s
PLC_PRG (FRG)
= {Z3 Task Configuration CaNspen 10 Mapping
=8 MairTask
@] pPLC_PRG Status
= [ canbus (cANbus)
= (1 canopen_Manager (CANopen_Manager) Information
(@ R_cor r-cor)
3 Devices | Modules
POUS > 1 x
=) corAIo_canfig -
@ Project settings
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Select Itermn from Object Directory x
Index:Subindex Mame AccessType Type Default al
+- 16#1003 Pre-defined error field

16#1005:16#00 COB-ID 5YNC RW UDINT 16%00000030
16#100C: 16#00 Guard Time RW UINT 16%00
16%100D: 16500 Life Time Factor RwW USINT 16700
- 16%1010 Store Parameters
+ 16%1011 Restore default parameters
16510141600 COB-ID EMCY RwW LIDIMT SNODEID +16+80
16#1015: 1600 Emergency Inhibit Time RW UINT 1e#00
+- 1621016 Consumer heartbeat time
16#1017:16#00 Producer heartbeat time RW UINT 16#00
+- 16%1029 Error behavior object
+- 16#1400 RxPDO 1 comm, parameter
+- 1671401 RxPDO 2 comm. parameter
+ 19#1402 RxPDO 3 comm, parameter
+- 16#1403 RxPDO 4 comm, parameter
- 1671404 RxPDO 5 comm. parameter
+- 16#1405 RxPDO & comm, parameter ™
MName: iR-COP Module1 register| |
Index: 163000 = Bit length:|16 =
SubIndex: 16#1 - Value: |
Cancel

Find iR-COP Address Mapping table in these user manuals:
For analog modules see UMQ18013E iR-Axxx-VI UserManual eng.pdf

For temperature modules see UM018014E iR-Axxx-TR UserManual eng.pdf

3.
CODESYS.

When finished, click [Online] » [Login] to download the project to

9.2.4 Using CODESYS to Set Channels (iR-ECAT)

1.
2.

Devices

> x [f] EthercAT Master

= ) Add EthercAT
= [ pevice (avT-CTRL)
= [0 PLC Logic
= I} Application
i) Lbrary Manager
B9 pLc_PRG (PRG)
=& Task Configuration
= MainTask

&) pic_PRG
[ iBus Bus)
=~ [ EtherCAT Master (EtherCAT Master)
=i R_ECAT (R-ECAT)
[ R_DM15 N (R-DM15-1)
R_AMOS VT (R-AM0ST)
[ R_AID4_TR (R-AI04-TR)

) EtherCAT_Master. EtherCAT Task

General

Process Data

Startup Parameters

EtherCAT /0 Mapping

Status

Information

Add iR-ECAT following the steps explained in Chapter 6 in this manual.
[iR_ECAT] » [Startup Parameters] » [Add]

Device iR_DM16_N [ R_ECAT x| PLC_PRG

|+ Aﬂdl A Edit 3 Delete & MoveUp & Move Down

Line  IndexSubindex  Name

Value Bitlength

Onemor 255 16
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Select Item from Object Directory

[] complete Access

3.
CODESYS.

-

[ Byte Array

9.3 Analog Channel |0 Mapping
9.3.1 Reading / Writing iR-ETN Channels

Index:Subindex MName Flags Type Default il
- 1657000: 16700 Digital Qutput RwW USINT
- 16%7010:16700 Analog Output RwW USINT
+- 16+800F: 16700 output value Farameter On error
= 16#8010: 16200 iR-AMO&-VI Parameter
:16#01 | Channel 0 Output Mode RW UINT 16#0001
116502 Channel 1 Output Mode RW UINT 160001
116#05 Channel 0 Output Scale Range Up... RW INT
116#06 Channel 1 Output Scale Range Up... RW INT
116#09 Channel 0 Qutput Scale Range Lo... RW INT
116#0A Channel 1 Output Scale Range Lo... RW INT
116%0D Channel 0 Update Time RW UINT 1650000
116#0E Channel 1 Update Time RW UINT 1650000
116%11 Error Code RW UINT 160000
116712 Command RW UINT 160000
116#13 Channel Detection R UINT 160000
116514 Conversion Time R UINT 1620000 s
Name Channel 0 Output Mode
Index: 16& 2010 = Bitlength: |18 =
SubIndex: 165 |1 = Value: 1 2

Cancel

When finished, click [Online] » [Login] to download the project to

1. [Modbus_TCP_Slave] » [Modbus Slave Channel] » [Add Channel]
MeodbusChannel =
Channel
Name iR-ETN AI Channel 0 |
Access Type Read Input Registers (Function Code 4) -
Trigger Cydic w | Cycle Time {ms) 100
Comment | |
READ Register
Offset | o |
Error Handling Keep last Value w
WRITE Register
Offset
Length 1
Concel
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Channel Input Function Code 3 & 4, Modbus address start from 0x0000.
Channel Output Function Code 6 & 16, Modbus address start from 0x0100.
See UMO018002E iR-ETN UserManual eng.pdf for information on:

Analog Input Mapping to Modbus (also applicable for temperature module).

Analog Output Mapping to Modbus.

2. Open PLC_PRG in Devices tree, create tag and set INT as data type. Write a

command as shown below.
1 PROGRAM PLC_PRG
VAR
AI Channel 0O
A0 Channel 0O
END VAR

[Ek]

LRI =

1|  20_Channel 0

INT ;
INT ;

:= AT Channel 0 ;

3. In Devices tree open Modbus_TCP_Slave » [ModbusTCPSlave I/0 Mapping]

tab and configure the settings.

General Find Filter Show all

Modbus Slave Channel Variable Mapping  Channel Address
#- 4§ Application.PLC_PRG.AT_Channel_0 "8 R-ETN AT Channel 0 Ly
Madbus Slave Init #- "% Application.PLC_PRG.AC_Channel_D "%  R-ETNAOChannel 0 [t

ModbusTCPSlave Parameters

ModbusTCPSlave /0 Mapping

Status

Information

Type Unit  Description
ARRAY [0..0] OF WORD
ARRAY [0..0] OF WORD

Read Input Registers
Write Multiple Registers

4. When finished, click [Online] » [Login] to download the project to

= ETN_AIO_Config hd Device.Application.PLC_PRG
= m Device [connected] (Weintek Built-n CODESYS) X
) Expression Type
= @1] PLC Logic

=i} Application [run]
m Library Manager
PLC_PRG (PRG)

@ AI Channel_0 INT
@ AO_Channel_0 INT

Value
5314
5314

Prepared value

= @ Task Configuration
= @ MainTask
#] PLC_PRG
= ﬁ Ethernet (Ethernet)
= m Modbus_TCP_Master (Modbus TCP Master)
m Modbus_TCP_Slave (Modbus TCFP Slave)

9.3.2 Reading / Writing iR-COP Channels
1. Add Analog module.

29
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) COP_AIO Config
= m Device (Weintek Built-in CODESYS)
=-E]) PLC Logic
=1L} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
=¥ MainTask
& PLC_PRG
=[] canbus (CANbus)
= m CAMopen_Manager (CAMopen_Manager)
=[] r_cor (r-cor)
[ R_aAT04_VI (R-AID4-VI)
[ ir_aqo4_vi (R-AQD4-T)

2. Open PLC_PRG in Devices tree, create tag and set INT as data type. Write a
command as shown below.
L PROGRAM FLC_PRG
VAR
COP_AT Channel 0 : INT ;
COP_&0 Channel 0 : INT ;
END VAR

[Tk

o

l| COP RO Chanmel 0 : COP AT Channel 0 »

3. In Devices tree open the list of Analog Module » [CANopen-Module 1/0
Mapping] tab and configure the settings.

CANopen-Module /0 Mapping Find Filter Show all -

Seos Variable Mapping  Channel Address Type
+- % COP_AI_Channel_0 @ Analog Input-16Eit : iR_AI04 VI BLIWD WORD

Information H- Anzlog Input-16Bit : iR_AID4 VI BRI 1 WORD
L ] Analog Input-16Bit : iR_AID4_VI %IW2 WORD
+ Analog Input-16Bit : iR_AID4_VI %IW 3 WORD

4. When finished, click [Online] » [Login] to download the project to
CODESYS.

9.3.3 Reading / Writing iR-ECAT Channels
1. Add Analog module.
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=[5 Add EtherCAT
= [l Device (@MT-CTRL)
=Bl PLC Logic
=-{L} Application
m Library Manager
W] PLC_PRG (PRG)
= @ Task Configuration
=58 MainTask
] EtherCAT Master.EtherCAT Task
] PLC_PRG
m iBus (iBus)
=[] EtherCAT_Master (EtherCAT Master)
=[] iR_ECAT (R-ECAT)
[ iR_AID4_VI (R-AI04-VT)
[ m_AQo4a_vI (R-AQ04VT)

2. Open PLC_PRG in Devices tree, create tag and set INT as data type. Write a

command as shown below.

1 FROGEAM FLC_FERG

2 VAR

3 ECAT AT Channsl 0 : INT ;
4 ECAT 20 Channsl 0 : INT ;
5 END VAR

3. In Devices tree open the list of iR-ECAT » [EtherCAT I/O Mapping] tab and

configure the settings.

CANopen-Module /0 Mapping Find Filter Show all -

Seos Variable Mapping  Channel Address Type
+- % COP_AI_Channel_0 @ Analog Input-16Eit : iR_AI04 VI BLIWD WORD

Information H- Anzlog Input-16Bit : iR_AID4 VI BRI 1 WORD
L ] Analog Input-16Bit : iR_AID4_VI %IW2 WORD
+ Analog Input-16Bit : iR_AID4_VI %IW 3 WORD

4. When finished, click [Online] » [Login] to download the project to
CODESYS.

9.3.4 Reading / Writing cMT-CTRLO1 Channels

1. Add Analog module.
= [ pevice (MT-CTRL)
=&l PLC Logic
=1} Application
m Library Manager
WF] PLC_PRG (PRG)
= @ Task Configuration
= Qﬁ MairiTask
H] pLC_PRG
= ﬂj iBus (jBus)
[ R_AMOS_VI (R-AMOS-VI)
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2. Open PLC_PRG in Devices tree, create tag and set INT as data type. Write a
command as shown below.

1 FROGEAM FLC _FRG

2 VAR

(XA}

ECAT AT Channsl 0 : INT ;

ECAT 20 Channel 0 : INT ;
END VAR

3. In Devices tree open the [iR_AMO06_VI] » [Module I/0 Mapping] tab and
configure the settings.

Module Parameters Find Filter Show all - &b Add FB for |0 Channel...

| Madule O Mapping Variable Mapping  Channel Address Type Unit Description

#) application.PLC_PRG.CTRL_AI_Channel_0 " A0 aepa

Status R AIL %IW2
R/ AL2 IW3

Information 3 AIZ IWSG iy Analog Input 3
"9 Application,PLC_PRG.CTRL_AQ_Channel_0 "% AQO B INT Analog Output 0
] 201 QW1 INT Analog Output 1

4. When finished, click [Online] » [Login] to download the project to
CODESYS.

9.4 Accessing Analog Module Registers Using Function Blocks

Before proceeding, make sure that the cMT+CODESYS Package has been downloaded
and installed.

AT-+CODESYS Firmware (HM CODESYS Firmware for HMI
cMT+CODESYS Firmware (HMI) 2023/02/23 20230204 irmware for Hi @
USe with Utility Manager from EBPro to update the firmware.

9.4.1 iR-ETN
1. Addthe [Ethernet], [Modbus_TCP_Master], and [Modbus_TCP_Slave]

devices, and configure their communication parameters. For detailed
instructions, refer to Chapter 5 of this manual:

[Device] » [Add device] » [Ethernet].

[Ethernet] » [Add device] » [Modbus_TCP_Master].
[Modbus_TCP_Master] » [Add device] » [Modbus_TCP_Slave].

= ﬂj Ethernet (Ethernet)
= m Modbus_TCP_Master (Modbus TCF Master)
ﬂj Modbus_TCP_Slave (Modbus TCP Slave)

2. Declare the ModbusRequest function block and its associated function
block parameters. Log in to CODESYS to proceed.
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Rnalog_Read:ModbusRequest;
pData:POINTER TO BYTE := ADR(Data):
Data:UDINT;
MB_Command: ModbusCormand;

END_VRR

Znalog_Read
TRUE ModbusRequest
EN ENO——
Modbus_TCP_Slave —Z slave xBusy
—|xExecute xDone

—|=Bbort xError
—|usilnitID XAborted
MB_Command —{ModbusCommand ModbusError

pData —{pSendData
pData —|pRecvData

3. After assigning address parameters in CODESYS, trigger “xExecute” to read
the data, which will be displayed in “Data”.

# @ Analog_Read ModhusRequest
POINTERTOBYTE  1654CsEBSC
UDINT 32000
MochusCommand

FunctionCode  MBFUNCTIONCODE  ReadHoldingRegisters
% uReadOffsdt  UINT 20025
% uiReadLen Ut 1

2% ModbusCommand's function code 3 (ReadHoldingRegister) is used to

read word addresses.
2% For Modbus address mapping, refer to “Analog Module Manual

Chapter 8” for detailed information.

9.4.2 iR-COP

1. Addthe [CANbus], [CANopen_Manager], [iR_COP], [iR_Module] devices,
and configure their communication parameters. For detailed instructions,
refer to Chapter 4 of this manual:
[Device] » [Add device] » [CANbus].
[CANopen_Manager] » [Add device] » [iR_COP].
[iR_COP] » [Add device] » [iR_AMO6_VI].

=[] canbus (CANbuz)
= m CAMopen_Manager (CAMopen_Manager)
=[] r_cor (r-coF)
[ ir_amos_v1_t (iR-AMOS-VT)

2. Declare the CIA405.SDO_READ function block and its associated function

block parameters. Log in to CODESYS to proceed.
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PROGRAM PLC FRG

VAR
pData:POINTER TO BYTE := ADR(Data);
Data:UDINT;
Size:UINT:=4;
Znalog_Read:CIA405.5D0 _RERD;

INDEX

END_VAR
Analeog Read
TRUE CIA405.SDO_READ
— ——¢=x B ENO|——

—NETWORK CONEIRM [
—ENAELE ERROR

— TIMEOQUT ERRORINFO —
—DEVICE

—|CHANNEL

SUBINDEX
pData — DATA
Size —=DATALENGTH

After assigning required parameters in CODESYS, trigger “ENABLE” to read
the data, which will be displayed in “DATA”.

# & pbata FOINTER TO BYTE 1654C6EBB48
# Data wNT 32000
& Size UINT 2

+ @ Analog Read  CIA%05.SDO_READ

—nETHORK ConFIRM

~{enaBLE

Too__|-{TrMEouT
TcE

2% The iR_COP Coupler Node_ID corresponds to the DEVICE. Refer to
[iR_COP] » [General] » [Node ID] for more information.
2% For INDEX and SUBINDEX address mapping, refer to “Analog Module

Manual Chapter 9” for detailed information.

iR-ECAT

Add the [EtherCAT_Master], [iR_ECAT], [iR_Module] devices, and configure
their communication parameters. For detailed instructions, refer to
Chapter 6 of this manual:

[Device] » [Add device] » [EtherCAT_Master].

[EtherCAT_Master] » [Add device] » [iR_ECAT].

[iIR_ECAT] » [Add device] » [iR_AMO6_VI].

= [ |EthercaT_master (EtherCAT Master) |
=[] R _ECAT (iR-ECAT)
) R_aMOB_VI (R-AMOG-VI)

Declare the ETC_CO_Read function block and its associated function block
parameters. Log in to CODESYS to proceed.
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PROGRAM PLC_ERG
VAR
Znalog Read:ETC_CO_SdoRead;
pData:POINTER TO UDINT := ADR{Data):
Data:UDINT:
Size:UDINT:=4;
END VAR
Analog_Read
TRUE ETC_CO SdoRead
F— =~ ENO—
xExecute xDone
xBbort xBusy

usiCom xError

usiChannel  udiSdoAbort
wIndex szDataRead
bySubindex

—(uiDevice eError

—udiTimeOut
phata —pBuffer
Size —|szSize

3. After assigning required parameters in CODESYS, trigger “xExecute” to read

the data, which will be displayed in “Data”.

+ & poata POINTER TOUDINT  1623C79A288
# Data womT 32000
# Sze omT 4

Znaleg_Read

ETC_CO_SdoRead

20U
pData [1€35cTsRa8s x
size[ 4 J—sesize

¢ The EtherCAT Coupler's address corresponds to uiDevice. Please refer to
[iR_ECAT] » [General] » [EtherCAT address] for more information.

s¢For module sequence addressing, use windex, where the Index address
of the first analog module is 16#8000.

¢ The address mapping for analog module's registers is done using
bySublindex.

9.4.4 cMT-CTRLO1
1. Under [iBus] » [Add device], add the analog module.

= m |iE|us (iBus) |
[ iR_AMOG_VI (R-AMOG-VI)

2.  Under [Library Manager] » [Add Library], add Weintek iBus Library.

=[5 Weintek Bus Lirary, 3.5. 10 (Weintek Labs. Inc.)
+-|) Base
=) Function Blacks
+ iBus_Info_Read
+-|Z] Bus_PU_Read
+[£] iBus_PU_Write
+ iBus_Req_Read
+-[E] Bus_Reg_write

3. Declare the iBus.iBus_Reg_Read function block and log in to CODESYS.
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PROGRAM FLC_ERG

Inalog_Read:ibus.iBus_Reg_Read;
END_VAH
Analog_Read
TRUE ibus.iBus_Reg Read
— ——ex ENO——

Execute Done
Device_Slot Busy
ModuleID Active
Rddress Error
ErrorID

Data

4. Input the desired parameter into the function block for reading, then
trigger "Execute" to display the current value in "Data".
sk For input parameter configuration, refer to "Weintek Library User
Manual Chapter 10 - Weintek iBus Library".

Analog_Read

10 Starting iR Motion Control Module

10.1 Motion Control Module Wiring
Please see UM019004E iR-PUO1-P_UserManual eng.pdf for information on wiring

when using iR-PU01-P module.

10.2 Setting Motion Control Module Parameters
10.2.1 Writing Motion Control Parameters from iR-ETN
1. AddiR-ETN following the steps explained in Chapter 5 in this manual.
2. Goto [Library Manager] » [Add library] and add Weintek CODESYS_Library
V1.0.0.3.
3. The Function Blocks for writing parameters to iR-PUO1P are placed in the
ETN_PU folder.
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+ Weintek = Weintek CODESYS Library, 1.0.0.3 (Weintek Labs. Inc.)

=5 Weintek CODESYS Library, 1.0.0.3 (Weintek Labs. Inc.)
=12 Weintek library
+-{0) WEINTEK_ANALOG
=) WEINTEK_MC_LITE

+-{_) Base

=) ETN_PU
+-1) Base
+ ETN_PU_AddPosition_Unit
+-[E] ETN_PU_axis_Setting
+ ETN_PU_DI_Filter
+ ETN_PU_DI_Setting
+-[E] ETN_PU_DO_abert_Option
+ ETN_PU_DO_Setting
£ ETM_PU_Home_Setting
+ ETN_PU_Max_Setting
+ ETN_PIJ_Motion_Config
+ ETN_PU_Mation_DIO_Setting
+ ETN_PU_Pulse_Method
+ ETN_PU_Pulse_Out_Urit
+ ETN_PU_PWM_Setting
+.[E] ETM_PU_SDO

+-[2) Function Blocks

4. Write iR-PUO1-P parameters in the program.

Deviems: %X @ hermt (@ wodusTonseve  a) cPRG x ([ Lbrary Manager

oo o)
= @ eteret Etheret
= [ Modbus TCP_Master (Modous TCP Master)
[ Modbus_TCP_Siave (Modus TCP Save)

cate Buay -
Dane -
se_Tnpur_Method Errer—

Shatt_fevolution
Modbus_S1ave

5. When finished, click [Online] » [Login] and download the project to
CODESYS. Trigger Execute to write parameters into iR-PUO1-P.

10.2.2 Writing Motion Control Parameters from iR-COP
1. Add iR-COP following the steps explained in Chapter 4 in this manual.
2. [iR_COP] » [SDOs] » [Add SDO]

Devices - R X [ R_cop x
='E cor.ar0_config -
=@ Device (Weintek Built-n CODESYS) General o AddSDO [ Edit 3 Delete # MoveUp & Move Down
= Bl PLc Logie Line IndecSubindex  Name Value  Bitlength  Comment
=08 Avolicats PDOS
£ Application

i Library Manager
PLC_PRG {PRG)
= {E3 Task Configuration

SDOs

CANopen /0 Mapping

=58 MairTask
8] pLc_prG Status
=i canbus (CANbUS)
=-( canopen_Manager (CANopen_Manager) Information

(@ r_cor (RoR)
3 Devices | I Modules

POUs - q x
=3 coP_Ao_Config -
@ Project Settings
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I__| WE!NTEK

Select Item from Object Directory x
Index:Subindex MName AccessType Type =
16#£5501: 1600 Axiz 0 Pulze Input Method™ : PUD1_Axis_0 RW USINT
16#5502: 16300 Axiz 0 Digital Input Polarity : PUD1_Axis_0 RW UDINT
+-- 16#5003 Axis 0 Digital Input Function
+- 16#5504 Axis 0 Digital Input Filter
+- 16#5510 Axis 0 Digital Output
16+5511: 16700 Axiz 0 Pulse Output Method™ : PUD1_Axis_0 R USINT
16+5512: 16500 Axiz 0 Digital Qutput Polarity : PUD1_Axis_0 R UDINT
+-- 16#5513 Axiz 0 Digital Qutput Function
+- 16%5514 Axiz 0 Digital Output abort connection option
+- 10#051A Axis 0 PWM Qutput settings
+-- 16#5520 Axis 0 Axis Settings0
+- 16#5521 Axis 0 Axis Settings1
+ - 16%5528 Axis 0 Additional position modula range
+- 16#5529 Axis 0 Additional home offset
+- 165530 Axis 0 Gear Motion Settings
+- 16#5540 Axis 0 CAM Motion Settings v
< miiig e o -
Mame: Unknown Object |
Index: 16%0 = Bit length:|8 =
SubIndex: 16#0 : Value: 0 |
Concel

See UMO019004E iR-PUO1-P UserManual eng.pdf for information on motion

control parameter configuration and object dictionary when using analog

modules.

3.  When finished, click [Online] » [Login] and download the project to
CODESYS.

10.2.3 Writing Motion Control Parameters from iR-ECAT
1. AddiR-ECAT following the steps explained in Chapter 6 in this manual.
2. [iR_ECAT] » [Startup Parameters] » [Add]

=3 Add EtherCAT -
= [ Device (cMT-CTRL)
= &l pLC Logic
=-IC} Application

[ Bus (Bus)
=[] EtherCAT Master (EtherCAT Master)
= [ ®_ECAT (RECAT)

General

Process Data

() Library Manager
B9 PLC PRG (FRG)
= {#8 Task Configuration
=% MairTask
(B EtherCAT_Master EtherCAT Task
&) pLc_PRG

Startup Parameters

EtherCAT /0 Mapping

Status

Information

[ PUD1_Axis_0 (R-PUO1-P Axis 0)
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Select [tem from Object Directory

Index:Subindex MName Flags  Type Def ™
16#5501: 16200 Axis 0 Pulse Input Method™® RW USINT
16%5502: 16700 Axis 0 Digital Input Polarity RW UDINT

- 165550316500 Axis 0 Digital Input Function

o 16#5504: 16500 Axis 0 Digital Input Filter

- 16%5510016=00 Axis 0 Digital Qutput
1e#5511:16%00 Axis 0 Pulse Qutput Method™ RW LISIMT
le#5512116=00 Axis O Digital Qutput Polarity RW LIDINT

+- 16%5513:116%00 Axis 0 DO Funiction

+ 16%5514:16%00 Axis 0 Digital Output abort connection option

+- 16#551A: 16500 Axis 0 PWM Qutput settings

+ 16#5520: 16500 Axis 0 Axis Settings0

+ 1e#5521: 16500 Axis 0 Axis Settings1

+ 16%5528:16%00 Axis 0 Additional position modulo range

+ 16#5529: 16200 Axis 0 Additional home offset

16%5530: 1600 Axis 0 Gear motion Settings hd
< >
Mame Axis 0 Pulse Input Method™
Index: 16% 5501 : Bitlength: 8 $
SubIndex: 16# 0 = Value: 1 = —

[ complete Access [ Byte Array

See UMO019004E iR-PUO1-P UserManual eng.pdf for information on motion

control parameter configuration and object dictionary when using analog

modules.

3.  When finished, click [Online] » [Login] and download the project to
CODESYS.

10.3 Motion Control Module I/O Mapping
10.3.1 Reading / Writing iR-ETN Channels
1. Add Weintek_CODESYS_Library and follow the steps in Chapter 5 in this
manual to add Modbus TCP device.

Devices v 3 X ¥ PLC PRG [ Modbus_TCP_slave (@ Ethernet
SR E T ~ || %5 Add library > Delete library | 57 Properties Details | 5] Plar
= Device (eMT-CTRL) N
= El] PLC Logic ame
+ 3

=-{} Application

m Library Manager s B
BF] PLC_PRG (PRG) s
= @ Task Configuration * :
= @ MainTask * B
& PLC_PRG Standard = Standard, 3.5.9.0 (System)
m iBus (Bus) + Weintek = Weintek CODESYS Library, 1.0.0.3 (Weintek Labs. Inc.)

= m Ethernet (Ethernet)
= m Modbus_TCP_Master (Modbus TCF Master)
m Modbus_TCP_Slave {Modbus TCP Slave)

2.  Add motion control channels and NMT network management channels.
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General Name Access Type Trigger READ Offset  Length  ErrorHandling  WRITEOffset  Length
0 Axis_0 Read)Write Multiple Registers (Function Code 23)  Cyclic, t1ms 1629C40 2 KeeplastValue  16%9E34 12
Modbus Slave Channel
1 NMTmansgement  Write Multiple Registers (Function Code 16) Cyciic, t2100ms 164FFF8 1

Madbus Slave Init
ModbusTCPS|ave Parameters
ModbusTCPSlave /O Mapping
Status

Information

3. Open PLC_PRG in Devices tree, create tag and set AXIS_REF_Lite as data

type. Edit motion control function blocks as shown below.

1| PROGRAM PLC_PRG - [&]
v
3| ETN_EU_FB 0 : weintek.ETN_PU_Pulse Method ; =
EIN_EU FB_1 : veincek.EIN_PU_Pulse Out Unit ;
EIN_FU FB 2 : weintek.EIN_PU Max_Setting ;
sExe : BOOL ;
7 Bxis 0 i weinoek.BEIS_REE_LITE ;
d Power_0 © weintek.MC_Power ;
s sEnable 0 : BOOL ;
19 T Managezens : WORD :
uf  Boover 100% @ v
= —
E£IN_PU_FB_0 EIN_PU_FB_L E£IN_PU_FB_2
TRUE eintek ETN PU_Pulse Nethod ointex BTN PU_Pulse Out Unit wointek BTN PU Max Setf
4‘ '7&1 - - E] N - - EN( - T
xExe —{Execute Busy [ ETN_PU_FB_0.Done —{Execute Busy| ETN_PU_FB_1.Done —{Execute
o —1{axis Done |- o —axis pone |- o —axis
4 —{eulse_Input Method Exzoz [ 1 —Encoder_Increments Exroz- 100000 —jHex_Erofile Velocizy
4—{Pulse_outpuc_Mechod 1 —Motor_Revolution 2000000 —{Max_Mosor_speed
1Modbus_TCP_S1ave —{Modbus_slave 1 —{Motor_shaft_Revolution 20000 —{Max_Acceleration
1 —Driving_Shaft_Revolucion 20000 —{Max_Deceleration
1—{Feed Modbus_TCP_S1ave —SModbus_Slave
1 —{Shaft_Revolution R
Modbus_TCP_Slave —S{Modbus_Slave
Eover_0
TRUE eintek MC_Power [ |
— ——ex = E E
Bxis_0 —lAxis Status - 2 WNMT_Management.
xEnable_0 —{Enable RegulatorRealState -
xEnable_0 —|RequlacorOn  DriveScartRealScate -
xEnable_0 — Drivestazt Busy [
Error [
Errorin [

4. In Devices tree open [iR-COP] » [CANopen |I/O Mapping] tab to configure
the settings.

Eerr Find Filter Show all -
Modbus Slave Channel Variable Mapging  Channel Address Type Uit Description
*- 4 Application.PLC_PRG.Axis_0.Mapping_L.Reg Kl Axis_0 Rl ARRAY [0..11] OF WORD Read,Write Multiple Registers
Modbus Slave Init & K’ Application.PLC_PRG.Axis_0.Mapping_Q.Reg T Axis_0 WG ARRAY [0..11] OF WORD Read/\Write Multiple Registers
" Application.PLC_PRG.wNMT_Management T NMT management B2 ARRAY [0..0] OF WORD Wirite Multiple Registers

ModbusTCPSlave Parameters
ModbusTCPSlave /0 Mapping
Status

Information

5. When finished, click [Online] » [Login] and download the project to
CODESYS. After triggering xExecute_0, iR-PUO1-P enters standstill state.

10.3.2 Reading / Writing iR-COP Channels
1. Add Weintek_CODESYS_Library.
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5 Add library $< Delete library | 25 Properties 55 Details | 5] Plac

E

B

&

EE

Mame

35license = 35License, 3.5.10.0 (35 - Smart Software Solutions Gmbt
BreakpointLogaging = Breakpoint Logging Functions, 3.5.5.0 (35 - 5ma
10DrvEtherCAT = IODrvEtherCAT, 3.5.10.0 (35 - Smart Software Sol
IoStandard = IoStandard, 3.5.10.0 (System)

Standard = Standard, 3.5.9.0 (System)

|Weintek = Weintek CODESYS Library, 1.0.0.3 (Weintek Labs. Inc.)

5 Witk CODESYS Livary, 1.0.0.3 (Waintek Labs. Inc,)
=D Weintek library

+-{2) WEINTEK_ANALOG
=) WEINTEK_MC_LITE
E2 E:I Base
+-122) EM_PU
=12 Function Blocks
+-[E] MC_cam_weintek
+ MC_Gear_Weintek
+ MC_Halt
- MC_Home
E: MC_Moveabsolute
+ MC_MoveRelative
+ MC_MoveVelodty
MC_Power
+ MC_Reset
+ MC_Stop

2. Add motion control modules.

Devices

=131 Add CANopen

ﬁ Device (Weintek Built-in CODESYS)
=& PLC Logic
=-IL} Application
m Library Manager
WF] PLC_PRG (PRG)
= @ Task Configuration
=38 MainTask
& PLC_PRG
= [ caMbus (CaMbus)
= ﬂj CAMopen_Manager (CAMNopen_Manager)
= [ ir_cor (r-cor)
[ PUO1_Axis_0 (PUO1-Axis )

3. Open PLC_PRG in Devices tree, create tag and set AXIS_REF_Lite as data

type. Edit motion control function blocks as shown below.

41

JoKyMeHT npefocTaBsieH KoMnaHuen "PycasTomaTuka". WWW.RUSAVTOMATIKA.COM


https://www.rusavtomatika.com/?utm=documents

cMT+CODESYS and Remote I/O Quick Start Guide

1 PROGRAM FLC ERG

2 VAR
3 Axis 0 : weintek.AXI5 REF LITE ;
4 Power_0 : weintek.MC Power ;
5 xEnable 0 : BOOL ;
& END VAR
1
Power_0
TRUE weintek .MC Power
11 EN a END
Axiz 0 —Haxis Status
¥Enable 0 —Enable RegulatorRealState
%Enable 0 —Regulator{n DriveStartRealState
xEnable 0 —DriweStart Busy
Error
ErrorID

4.
the settings.

L_| WE!NTEK

In Devices tree open [iR_COP] » [CANopen 1/O Mapping] tab and configure

General Find Filter Show all -

_ Variable Mapping  Channel Address Type
+ "% Application. PLC_PRG. Axis_0.Mapping_Q.0b}.DO_BO " s 0DObyte 0 : PUOL_Axis 0 %BS  USINT

SDO0s +- " Application PLC_PRG.Axis_0.Mapping_Q.0bj.ModeOp “® Axis 0 Modes of operation : PUD1_Axis_0 %GB SINT
* "% Application. PLC_PRG. Axis_).Mapping_Q.0bj.Controlword " Axis 0 Controlword : PLI1_Axis_D W UINT

CANopen 1fO Mapping +- " Application. PLC_PRG. Axis_.Mapping_Q.0bj.TargetVelocity " s 0 Terget velodity : PUD1_Axis_0 *eB+  DINT
+- " Application.PLC_PRG. AXis_0.Mapping_Q.0b. TargetPosition % Axis 0 Target position : PUO1_Axis_0 %aB2 DINT

Status +- "% Application PLC_PRG. Axis_0.Mapping_0Q.0bj.ProfileVelocity 9 Axis 0 Profile velocity : PU01_Axis_0 %ep3 UDINT
+ "% Application.PLC_PRG. Axis_0.Mapping_Q.Obj.ProfileAcc " Axis 0 Profile acceleration : PUOT_Axis 0 %S4 UDINT

information +- " Applcation PLC_PRG. Axis_0. Mapping_Q.0b}.ProfileDec 7% Axis 0Profle deceleration : PUD1_Axis_0 %85 UDINT
*+ % Application. PLC_PRG. Axis_0.Mapping_1.Obj.DI_BO " Axis 0DIbyte 0 : PUOY_Axis 0 B0 USINT
*+ 4 Application. PLC_PRG, Axis_0.Mapping_LOGj.ModeOpDisp “#  Axis 0 Modes of operation display ; PUD1 Axis 0 g SINT
+ *p Application PLC_PRG, Axis_0.Mapping_1Obj.Statusword " s 0 Statusword 1 PUDT_Axis_0 s UINT
+- % Application. PLC_PRG. Axis_.Mapping_L Obj.PositionActual " s 0 Position actual value : PLD1_Axis_0 == DINT
*+ 4 Application PLC_PRG, Axis_0.Mapping_LOGj.Velodity Actual T Axis 0 Velodity actual value : DI Axis 0 EE=) DINT
*- *p Application PLC_PRG, Axis_0.Mapping_I.Obj.PositionDemandinternal ¥ Axis 0 Position demand internal value : PUD1_Axis_0 et DINT
% Application. PLC_PRG. Axis_0.Mapping_I.0bj.DO_Status_B0 T s 00O status byte 0 : PUD1_Axis 0 B USINT
*+- 4 Application. PLC_PRG,Axis_0.Mapping_1.0Bj.CAP_Status B0 T Axis 0 Capture status byte 0 : PUOL Axis 0 WBEF USINT
* *p Application PLC_PRG, Axis_0.Mapping_L.Obj.ErrorCode ¥ Axis 0 Error code : PUO1_Axis_0 et UINT
+- % Application. PLC_PRG. Axis_0.Mapping_I.Obj.AddPositonActual “$ s 0 2nd additional position actual value : PUD1_Axis_0 B DINT

5.

After triggering xExecute_0, iR-PUO1-P enters standstill state.

10.3.3 Reading / Writing iR-ECAT Channels
1. Add Weintek_CODESYS_Library.
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5 Add library $< Delete library | 25 Properties 55 Details | 5] Plac

Mame
+ 35license = 35License, 3.5.10.0 (35 - Smart Software Solutions Gmbt
+ BreakpointLogaging = Breakpoint Logging Functions, 3.5.5.0 (35 - 5ma
E 10DrvEtherCAT = IODrvEtherCAT, 3.5.10.0 (35 - Smart Software Sol
+ IoStandard = IoStandard, 3.5.10.0 (System)

Standard = Standard, 3.5.9.0 (System)
+ |Weintek = Weintek CODESYS Library, 1.0.0.3 (Weintek Labs. Inc.)

=5 Weaitsk CODESYS Library, 1.0.0.3 (Weintek Labs. Inc,)
=D weintek library
+-{2) WEINTEK_ANALOG
=) WEINTEK_MC_LITE
E2 E:I Base
+-122) EM_PU
=12 Function Blocks
+-[E] MC_cam_weintek
+ MC_Gear_Weintek
+ MC_Halt
- MC_Home
E: MC_Moveabsolute
+ MC_MoveRelative
+ MC_MoveVelodty
MC_Power
+ MC_Reset
+ MC_Stop

2. Add motion control modules.

=3 Add FthercAT
=[] Device (cMT-CTRL)
=-El PLC Logic
=1L} Application
m Library Manager
B pLC_PRG (PRG)
= @ Task Configuration
=58 MainTask
] EtherCAT Master EtherCAT Task
] PLC_FRG
m iBus (iBus)
=[] EtherCAT_Master (EtherCAT Master)
=[] ir_ECAT (RECAT)
[ PuD1_Axis_0 GR-PUD1-P Axis O)

3. Open PLC_PRG in Devices tree, create tag and set AXIS_REF_Lite as data
type. Edit motion control function blocks as shown below.
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L_|WE

NTEK

1 PROGRAM FLC ERG

2z VAR

3 Rxisz 0
4 Power_0

: welntek.RXIS REF LITE ;

5 xEnable 0

£ END VAR

TRUE

weintek.MC_Power ;

BOOL ;

Power_0

weintek.MC Power

4.
the settings.

Variable
"4 application PLC_PRG. Axis_0.Mapping_Q.0bj.D0_B0

" Application PLC_PRG. Axis_0.Mapping_Q.Obj.ModzOp

"# Application.PLC_PRG. Axis_0.Mapping_Q.Obj.Controiword
" Application PLC_PRG. Axis_0.Mapping_Q.Obj. TargetVelocity
" application PLC_PRG. Axis_0.Mapping_Q.Obj. TargetPosition
" Application PLC_PRG.Axis_0.Mapping_Q.Obj.ProfileVeloity
" Application.PLC_PRG.Axis_0.Mapping_Q.Obj.ProfileAcc

" Application PLC_PRG, Axis_0.Mapping_Q.Obj. ProfleDec

&

#p Application.PLC_PRG.Axis_0.Mapping_I.0bj.DI_BO

* Application.PLC_PRG. Axis_0.Mapping_1.Obj.ModeOpDisp

4 Application PLC_FRG. Axis_0.Mapping_1.0bj Statusword

*# Application.PLC_PRG. Mapping_1.0bj.PositionActual

*# Application PLC_PRG.Axis_0.Mapping_1.0bj.VelodityActual

* Application.PLC_PRG. Axis_0.Mapping_.Obj PositionDemandInternal
% Applcation PLC_PRG.Axis_0.Mapping 1.0b1.D0_Status_BO

*# Application PLC_PRG.Axis_0.Mapping_1.0bj.CAP_Status_BO0
* Application PLC_PRG.Axis_0.Mapping_1.0bj.ErrorCode

% Application PLC_PRG.Axis_0.Mapping_I.0bj.AddPositionActual
hd

»

5.

Axiz 0 —Haxis
¥Enable 0 —Enable
%Enable 0 —Regulator{n

xEnable 0 —DriweStart

Mzpping

FddEEd

dedddddddd

EN ERQ——
Status [—
BegulatorBRealState

DriveStartRealState

Busy [—
Error —
ErrorID—

In Devices tree open [iR_ECAT] » [EtherCAT I/O Mapping] tab and configure

Channel Address Type  Unit  Description

PUO1_Axis_D Axis 0 DO byte 0 B USINT PUD1_Axis_0 Axis 0 DO byte 0
PLO1_Axis_0 Axis 0 Mode of operation ®eBt  USINT PUD1 Axis_0 Axis 0 Mode of operation
PLO1_Axis_0 Ais 0 Controlnerd HQws  UNT PUD1_Asis_0 Asis 0 Controlword
PUO1_xis_0 Axis O Target velocty %Qd:  DINT PUD1_Axis_0 Axis 0 Target velodty
PUO1_Axis_0 Axis O Target position %ep2  DINT PUD1_Axis_0 Axis 0 Target position
PLO 1 Axis_0 Axis 0 Profil velodity ®RPE:  UDINT PLO1_Axs_0 Axis 0 Profile velocity
PLO1_Axis_0 Axis 0 Profie acceleration %84 DINT PUD1_Axis_0 Axis 0 Profile acceleration
PUO1_Axis_0 Axis 0 Profie deceleration %oes  DINT PLID1_Axis_0 Axis 0 Profile deceleration

PUO1_Axis_0 Reserved
PUO1_Axis_0 Reserved

%QD6  DINT
%QD7  DINT

PUD1_Axis_0 Reserved
PUD1_Axis_0 Reserved

PLO1_Axis_0 Axis 0 DI byte 0 =1 USINT PUD1_Aoxis_0 Ais 0 Dl byte 0
PLO1_Axis_0 Axis 0 Mode of operation display 85 UsINT PUD1_Asis_0 Asis 0 Mode of operation dispiay
PUO1_Axis_0 Axis 0 Statusword wws  UNT FUD1_Axis_0 Axis 0 Statusnord

PUO1_Axis_0 Axis 0 Position actual value e ot PUD1_Axis_0 Axis 0 Position actual value

PLO L Axis_0 Axis 0 Velodity actual value £ oIt PUDL Axis_ Axis 0 Velocity actual value

PLO 1_Axis_0 Axis O Pesition demand internal value s oIt PUD1_Axis_0 Asxis 0 Position demand internal value
PUO1_Axis_0 Axis 0 DO status byte 0 wBB|  USINT PUD1_Axis_0 Axis 01DO status byte 0

PUD1_Axis_0 Axis O Capture status byte 0 B2 USINT PUD1_Axis_0 Axis 0 Capture status byte 0
PLO1_Axis_0 Axis O Error code W UINT PUD1_Axis_0 Axis 0 Error code

PLO1_Axis_0 Axis 0 2nd additional position actual value s oINT PLD1_Aoxis_0 Asis 01 2nd edditional position actual value
PUO1_Axis_0 Reserved %07 oIt PUD1_Axis_0Reserved

PUO1_Axis_0 Reserved %108 ot FUD1_Axis_0Reserved

When finished, click [Online] » [Login] to download the project to CODESYS.

After triggering xExecute_0, iR-PUO1-P enters standstill state.

10.3.4 Reading / Writing cMT-CTRLO1 Channels

1.

Add Weintek_CODESYS_Library.
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%5 Add library 3 Delete library | 57 Properties T3 Details | 5] Plac

MName
k2 35License = 3SLicense, 3.5.10.0 (35 - Smart Software Solutions Gmbt
+ BreakpointLogging = Breakpoint Logaing Functions, 3.5.5.0 (35 - Sma
E3 I0DrvEtherCAT = IODrvEtherCAT, 3.5.10.0 (35 - Smart Software Sol
+ IoStandard = IoStandard, 3.5.10.0 (System)

Standard = Standard, 3.5.9.0 (System)
+ |Weintek = Weintek CODESYS Library, 1.0.0.3 (Weintek Labs. Inc.)

=5 Weintek CODESYS Library, 1.0.0.3 (Weintek Labs. Inc.)
=) Weintek library
+-1) WEINTEK_ANALOG
=) WEINTEK_MC_LITE
+ E.'_I Base
412 ETN_PU
=12 Function Blocks
+ MC_Cam_Weintek
+-[E] Mc_gear_weintek
+ MC_Halt
- MC_Home
E MC_MoveAbsolute
+ MC_MoveRelative
+ MC_MoveVelodty
MC_Fower
+ MC_Reset
+-[E] Mc_stop

2. Add the motion control module.
=[] pevice (MT-CTRL)
=8 PLC Logic
= a Application
m Library Manager
W] PLC_PRG (PRG)
= @ Task Configuration
=% MainTask
& pLC_PRG
= ﬂj iBus (iBus)
[ r_PuD1_P (R-PUDLF)
3. Open PLC_PRG in Devices tree, create tag and set AXIS_REF_Lite as data

type. Edit motion control function blocks as shown below.
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[

FROGRAM FLC_FRG
VRR

Bxis 0O
Power_0 :

xEnable 0 : BOOL ;

END VAR

weintek.AXIS _REF LITE ;
weintek.MC_Power ;

Poawer_0

L_|WE

TRUE
11 EN

Axiz_0 —Fnxis

xEnable 0 —Enable
xEnable 0 —RegulatorOn
xEnable 0 —DriveStart

weintek .MC Power

ERQ——

Status [—

BegulatorBRealState [—
DriwveStartRealState
Busy —

Error —

ErrorID —

NTEK

4. In Devices tree open [iR_ECAT] » [EtherCAT I/O Mapping] tab and configure
the settings.

| Module Parameters Find Filter Show il ~ b Add FB for IO Channel. Goto Instance

| Module 70 Mapping Variable Mapping ~ Chan Address  Type

#p Appication PLC_PRG. Axis_0.Mapping_1.0bj.DI_BO “® E== SINT
Status *p Appication PLC_PRG, Axis_0.Mapping_1.0b)Mod=OpDisp " 2B
*p Appication PLC_PRG.Axis_0.Mapping_1.0bj.Statusword ] *nuz
Information *p Application.PLC_PRG.Axis_0.Mapping_1.Obj.PositionActual Tp —_—
R 1, (=)
* Applicat ._PRG. Axis_0 May internal ¥ B4
*p Appication PLC_PRG.Axis_0. 1 _Status “® B2

*p Application.PLC_PRG.Axis_0.Mapping_1.Obj.CAP_Status_BO ] prE-tty SIN

* Application PLC_PRG.Axis_0 Mapping_1.0b) ErrorCode K] waws: | UNT

*# Appication.PLC_PRG. Axis_0.Mapping_1.0bj.AddPositionActual # %6 INT

%7 o

hd %08 DIV

*i$ Appication.PLC_PRG.Axis_0.Mapping_Q.0b}.D0_BO “p DO byte 0 3080 USINT Digital Output

b A PLC_PRG. Axis_0.Mapping_Q. Obj.Mox Tp s SINT

" A PLC_PRG. Axis_0.Mapping_Q.Obj.Controluor # %aw:  UINT

" A PLC_PRG. Axis_0.Mapping_Q.Obj.Targe tVelocity ® HEet  DINT

" Appication,PLC_PRG.Axis_0,Mapping_Q.Obi.TargetPosition “® ®eo2  DINT

"4 Appication PLC_PRG.Axis_D.Mapping_Q.Obj.Prafilevelocity T Profie B3 UDINT

"$ Appiccation.PLC_PRG.Axis_0.Mapping_Q.Obj.ProfileAcc “p rofile prr=eyy UDINT

"# Appiication PLC_PRG.Axis_0.Mapping_Q. Obj.ProfileDec % ms UDINT

"% QD6 UDINT

" %QD7  DINT

5. When finished, click [Online] » [Login] to download the project to CODESYS.
After triggering xExecute_0, iR-PUO1-P enters standstill state.

10.4 Accessing Motion Control Module Registers Using Function Blocks

10.4.1 iR-ETN

1. Addthe [Ethernet], [Modbus_TCP_Master], and [Modbus_TCP_Slave]
devices, and configure their communication parameters. For detailed

instructions, refer to Chapter 5 of this manual:

[Device] » [Add device] » [Ethernet].
[Ethernet] » [Add device] » [Modbus_TCP_Master].
[Modbus_TCP_Master] » [Add device] » [Modbus_TCP_Slave].

= ﬂj Ethernet (Ethernet)
= m Modbus_TCP_Master (Modbus TCF Master)
ﬂj Modbus_TCP_Slave (Modbus TCP Slave)

2. Under [Library Manager] » [Add Library], add Weintek_CODESYS_Library.
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3. Declare the weintek.ETN_PU_SDO function block and its associated
function block parameters. Log in to CODESYS to proceed.

PROGRAM PLC_FPRG
VAR
PU_Read:weintek.ETN_PU_SDO;
Data:weintek.Modbus_Data;
END VAR

PU_Read
weintek.ETN PU S5DO
EN ~ ENO|—
Read Busy
Write Done

==
=G

Index Error
Sub_Index
Length
Modbus_TCP_Slave —Modbus_Slave

Data —Data

T 11 1 1 1

4. After assigning address parameters in CODESYS, trigger “Read” to read the
data, which will be displayed in “Data”.

* @ PU_Read weintek.ETN_PU_SDO
= # Data weintek.Modbus_Data
* ¢ abData ARRAY [0..3] OF BYTE
+ % ausiData ARRAY [0..3] OF US...
* § aiDats ARRAY [0..1] OF INT
* ¢ awData ARRAY [0..1] OF W.
% diData DINT 1
# dwbData DWORD 1

T -
e By
[zx7es]
o] sue_
9

[Modbus_TCE_Slave —5

Data —

2% For Index and Sub_Index address mapping, refer to “iR-PU01-P User

III

Manual” for detailed information.
10.4.2 iR-COP
1. Addthe [CANbus], [CANopen_Manager], [iR_COP], [iR_Module] devices,
and configure their communication parameters. For detailed instructions,
refer to Chapter 4 of this manual:
[Device] » [Add device] » [CANbus].
[CANopen_Manager] » [Add device] » [iR_COP].
[iR_COP] » [Add device] » [iR_PUO1_P].
=[] cANbus (CANbus)
= m CAMopen_Manager (CAMopen_Manager)

= r_cor (r-CoF)
[ PUD1_Axis_0_1 (PUD1-Axis 0)

2. Declare the CIA405.SDO_READ function block and its associated function
block parameters. Log in to CODESYS to proceed.
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PROGRAM FLC_FRG
VAR
pData:POINTER TO BYTE := ADR({Data);
Data:UDINT;
Size:UINT:=4;
FU_Read:CIA405.5D0 RERD;
END VAR

PU_Read

CIA405.5D0 READ
EN ENO—

=
=]
=

NETWORK
ENRAELE
TIMEQUT

CONFIRM
ERROR
ERRORINFC

DEVICE
CHENNEL
INDEX
SUBINDEX
pData —DATR

3ize —|DATALENGTH

3. After assigning required parameters in CODESYS, trigger “ENABLE” to read
the data, which will be displayed in “DATA”.

+ % phata POINTER TO BYTE 1624C6EBB48
# Data UDINT 1
size umT
* 4 PURead CIA405.500_READ

2% The iR_COP Coupler Node_ID corresponds to the DEVICE. Refer to
[iR_COP] » [General] » [Node ID] for more information.
2% For INDEX and SUBINDEX address mapping, refer to “iR-PU01-P User

Manual” for detailed information.

10.4.3 iR-ECAT

1. Addthe [EtherCAT_Master], [iR_ECAT], [iR_Module] devices, and configure
their communication parameters. For detailed instructions, refer to
Chapter 6 of this manual:
[Device] » [Add device] » [EtherCAT_Master].
[EtherCAT_Master] » [Add device] » [iR_ECAT].
[iR_ECAT] » [Add device] » [iR_PUO1_Axis_0].

=[] EtherCAT_Master (EtherCAT Master)
=[] ®_ECAT (R-ECAT)
[ PUO1_Axis_0 (R-PUD1P Axis 0)

2. Declare the ETC_CO_Read function block and its associated function block

parameters. Log in to CODESYS to proceed.
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PROGRAM PLC FRG

VAR
BU_Read:ETC_CO_SdoRead;
pData:POINTER TO UDINT := ADR(Data);
Data:UDINT;
Size:UDINT:=4;
END_VAR
PU_Read
TRUE ETC CO SdoRead
F— = - ENO——
—|xExecute xDane —
—|xAbort xBusy —
—|usiCom HETrror —
—|uiDevice eError —
—{usiChannel udiSdoRbort —
—|windex szDataRead [—
—bySubindex
—|udiTimeOut
pData —{pBuffer
Size —3z5ize

3. After assigning required parameters in CODESYS, trigger “xExecute” to read

the data, which will be displayed in “Data”.

* & pData POINTERTOUDINT  16#3C79A288
# Date UDINT 1
@ size UpINT 4

1] PU_Read

r.:lrz ETC_CO_SoRead
T ecute one T

[
55 -{uarTineous
poate pouceer
sizel s F{essize

¢ The EtherCAT Coupler's address corresponds to uiDevice. Please refer to
[iR_ECAT] » [General] » [EtherCAT address] for more information.
s¢For address mapping using windex and bySublindex, refer to “iR-PU01-P

User Manual” for detailed information.

10.4.4 cMT-CTRLO1
1. Download and install the cMT+CODESYS Package.

| AT ES E 2 CONE Eirmw ~r HM
cMT+CODESYS Firmware (HMI) 2023/02/23 20230204 ._(:D_ETYS |||?ma‘|e for HMI @
USe with Utility Manager from EBPro to update the firmware.

2. Under [iBus] » [Add device], add the motion control module.

= ﬂj|iBus (iBus) |
[ r_PUD1_P (R-FUDLF)

3.  Under [Library Manager] » [Add Library], add Weintek iBus Library.

=13 Weintek Bus Library, 3.5, 10 (Weintek Labs. Inc.)
+-IZ) Base
=) Function Blocks
+ iBus_Info_Read
iBus_PU_Read
Bus_PU_Write
iBus_Req_Read
iBus_Reg_Write

+

+
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4. Declare the iBus.iBus_PU_Read function block and log in to CODESYS.

PU_Read:ibus.iBus_PU Read;

PU_Read
TRUE ibus.iBus_PU Read

{1 EN ENO——

—Execute Done [~

—DewicePU Busy [~

—Index Active [~

—Subindex Error

ErrorID —

DataLength [~

Data [~

5. Input the desired parameter into the function block for reading, then
trigger "Execute" to display the current value in "Data".
sk For input parameter configuration, refer to "Weintek Library User
Manual Chapter 10 - Weintek iBus Library".

PU_Read
ibus.iBus PU Read

TRUE

L]
FALSE
FALSE
FALSE

11 Starting Driver

11.1 CANopen Driver
1. Add Weintek CODESYS_Library.

— s s srm s g ey

+ |Weinhek = Weintek CODESYS Library, 1.0.0.5 {Weintek Labs. Inc.)

=51 Weinfek CODESYS Library, 1.0.0.5 (Weintek Labs. Inc.)
=12 Weintek library
+-{0) VAR_ACCESS
+-I2) WEINTEK_ANALOG
=) WEINTEK_MC_LITE
+-IZ) Base
+-2) ETN_PU
=2 Function Blocks
+-[E] MC_cam_weintek
+-[E] MC_Gear_Weintek
+-[E] Mc_Halt
* MC_Home
+ MC_MoveAbsolute
% MC_MoveRelative
+-[E] MC_Movevelodty
MC_Power
+-[E] MC_Reset
+-[E] Mc_stop
E? MC_TorqueControl
-2 PU_PWM
+-2) Unions

2. Add CANbus, CANopen_Manager, CANopen drivers.
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=gl CAN Nefwork Controf -
= ﬂj Device (Weintek Builtin CODESYS)
=-E PLC Logic
=1L} Application
m Library Manager
HF| PLC_PRG (PRG)
= @ Task Configuration
=gk MainTask
& PLC_PRG
=[] cambus (CAMbus)
= ﬁ CAMopen_Manager (CAMopen_Manager
m ASDA_AZ_Drive (ASDA-AZ Drive)

3. CANbus -> Baudrate settings:

General

CANbus Parameters orks ] = cn"
Network: -
CANbus /0 Mapping Baudrate (bit/s): 250000 w

Status

| General

Information

CODESYS baudrate must be identical to the driver’s baudrate.
4. CANopen driver settings:

(1) Node ID
General General
PDOs Mode ID: |11 = cn"@p@ﬂ
SD0s [] Enable Expert Settings

[[] Enable Sync Praducing
CANopen Parameters

Nodeguarding
CANopen If0 Mapping

Emergency TIME

Status Checks at Startup

Information

Node ID settings must be identical to that of the driver.
(2) PDO settings:

Receive PDOs (Master == Slave)

ok Add PDO gk Add Mapping [ & Edit Delete Move Up Move Down

Mame Object Bit length
v| 16#1400: Receive PDO Communication Parameter 16#20B ($NODEID+16#200) 56
Controlword 16#6040:16200 16
Modes of aperation 16#6060:16200 8
Target velocity 16#60FF: 16200 32
v| 16#1401: Receive PDO Communication Parameter 16#30B ($NODEID+16#300) 64
Target Position 16#607A: 16500 32
Profilevelocity 16%6081:16:00 32
v| 16#1402: Receive PDO Communication Parameter 16#40B ($SNODEID+16#400) 64
Profile acceleration 16%6083:16500 3z
Profile deceleration 16£6084:16300 32

See Axis Variable Instance Mapping_Q to add variables for output
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channels.

Transmit PDOs (Slave => Master)

ok Add PDO =k Add Mapping [ 2 Edit Delete Move Up Move Down

MName Object Bit length

v 1681800: Transmit PDO Communication Parameter 16#18B ($NODEID+16#180) 56
Modes of operation display 16%6061:16200 8
Statusword 16#6041:16#00 16
Position actual value 16#6064:16#00 32

v| 16&#1801: Transmit PDO Communication Parameter 16£28B ($NODEID+16&280) 64
Velodty actual value 16#606C:16%00 32
Position demand value® 16#60FC: 16200 32

See Axis Variable Instance Mapping_| to add variables for input channels.
(3) SDO settings:

General gk Add 500 | & Edit Delete Move Up Move Down
30s Line  Index:subindex Mame Value Bit length
1 16#607F: 16500 Max profile velocty 200 32
SDOs 2 16%6080: 1600 Max motor speed 200 32
3 16#6085: 16200 Quick stop deceleration 200 32
CANopen Parameters 4 16#60C5: 16500 Max acceleration 200 32
5 16#60C6: 16200 Max deceleration 200 32

CANopen If0 Mapping

Status

Information

Follow the settings in the screenshot above to set initial values for checking
motor rotation.
(4) CANopen I/0O Mapping:

Find Filter Show all he
Variable Mapping  Channel Address Type
Ty Application.PLC_PRG. Axis_0.Mapping_Q).Obj. Controlword ] Controlword SLORMG UINT
- T Application,PLC_PRG.Axis_0.Mapping_Q.0bj.ModeCp "% Modes of operation LR SINT
+--"@ Application.PLC_PRG.Axis_0.Mapping_Q.Obj. Targetvelacity ] Target velodty opd DINT
+- g Application.PLC_PRG.Axis_0.Mapping_Q.Obj. TargetPosition "o Target Position o DINT
+--" Application.PLC_PRG.Axis_0.Mapping_.Obj.ProfileVelocity " Profile velocity SLabs UDINT
e Application. PLC_PRG. Axis_0.Mapping_Q).Obj.ProfileAcc " Profile acceleration 2ong UDINT
=T Application.PLC_PRG.Axis_0.Mapping_Q.Obj.ProfileDec "% Profile deceleration SLapE UDINT
+- 4 Application.PLC_PRG.Axis_0.Mapping_.Obj.ModeOpDisp " Modes of operation display Eect SINT
+- 4 application,PLC_PRG.Axis_0.Mapping_T.Obj.Statusword " Statusword ST UINT
+- 4§ Application.PLC_PRG.Axis_0.Mapping_.Obj.PositionActual " Position actual value =t DINT
+- 4 application.PLC_PRG.Axis_0.Mapping_T.0bj.VelodityActual " Velodity actual value o= b DINT
+- 4% application.PLC_PRG.Axis_0.Mapping_I Obj.PositionDemandInternal "% Position demand value® s =r] DINT

Mapping_| and Mapping_Q should be mapped to CANopen |I/O Mapping.

5. Programming:
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1 PROGRAM FLC_FRG

L_I WE!NTEK

2 WAR
Awis 0 : weintek.RXIS REF LITE ;
Power_0 : weintek.MC Power ;
INC 0 : weintek.MC_MoveRelative ;
xEnable : BOOL ;
7 xINC Exe : BOOL ;
diDistance : DINT := 10000
udiVel : UDINT := 10000
1 udifcc @ UDINT := 1000
11 udiDec : UDINT := 1000
12 END VAR
1
Power_0
TRUE weintek .MC Power
11 EN B ENO——
Axis 0 —SAxis Status -
®xEnable —Enable RegulatorRealState —
xEnable —RegulatorOn DriveStartRealState [
xEnable —DriwveStart Busy —
Error —
ErrorID
2
INC_0O
IRUE weintek .MC MoveRelative
11 EN - ENO——
Axiz 0 —SAxis Done
XINC_ Exe —Execute Busy [~
diDistance —Distance Active [~
udiVel —Velocity Commandiborted —
udilce —Acceleration Error —
udilDec —Deceleration ErrorID —
—_BufferMode
—_I0_Ctrl

Function blocks MC_Power & MC_MoveRelative are needed for testing motor

rotation.

Trigger “xEnable” and then trigger “xINC_Exe” to give command to the motor to
perform positioning. When MC_Power.Status = FALSE, use MC_Reset function

block to reset the motor and then trigger “xINC_Exe”.

#& Function blocks that can give command

to the motor can be found in

Weintek_MC_LITE folder in Weintek Library.
For more information, please see the following user manual.
UMO018017E CODESYS Weintek Library UserManual eng

11.2 EtherCAT Driver
1. Add Weintek_CODESYS_Library.
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— g s s g oy

+ |Weinhek = Weintek CODESYS Library, 1.0.0.5 (Weintek Labs. Inc.)

2.

5] Weintek CODESYS Library, 1.0.0.5 (Weintek Labs. Inc.)
=12 Weintek library
+-[J) VAR_ACCESS
+-|2) WEINTEK_ANALOG
=) WEINTEK_MC_LITE
+-|Z) Base
+-2) ETN_PU
=2 Function Blocks
+-[2] mc_cam_weintek
+-[E] MC_Gear_Weint=k
+-[2] mc_Halt
* MC_Home
L MC_MoveAbsolute
ks MC_MoveRelative
+-[E] MC_Mavevelodty
MC_Power
+-E] Mc_Reset
+-[E] Mc_stop
+ MC_TorqueControl
+-122) PU_PWM
+-) Unions

Add EtherCAT_Master, EtherCAT drivers.

3.

-

=il ECAT _Network Control
= [ Device (cMT-CTRL)
=18 PLC Logic
=1L} Application
m Library Manager
W¥F] PLC_PRG (PREG)
= @ Task Configuration
- g EtherCAT Task
& EtherCAT_Master, EtherCAT
=-$& MainTask
& pLC_PRG
ﬁ iBus (jBus)
=-[f] EtherCAT_Master (EtherCAT Master)
(1] AsDA_AZ_E_CoE_Drive_1 (Delta ASDAA

EtherCAT_Master -> Source Address(MAC):

General Autoconfig Master/Slaves

Sync Unit Assignment EtherCAT NIC Setting

EtherCAT Parameters Destination Address{MAC) FF-FF-FF-FF-FF-FF

I__| WE!NTEK

EtherCAT. ™

Broadcast [ | Enable Redundancy
—

ISourceAddress(MAc) [00-0c-26-18-43-34 |

| Browse... I

EtherCAT /O Mapping

Network Name ethd

Status (@) Select Network by MAC

Information Distributed Clock

4000
20

Cycle Time ps

A ||

Sync Offset
|:| Sync Window Maonitoring

Sync Window 1 ps

4. EtherCAT driver settings:

54

() Select Network by Name

Options

[JOoKyMeHT npefocTaBsieH KoMMaHmen "PycaBToMaTuka"

. WWW.RUSAVTOMATIKA.COM


https://www.rusavtomatika.com/?utm=documents

(1) Process Data

cMT+CODESYS and Remote I/O Quick Start Guide

I__|b WE!NTEK

Select the Inputs

Select the Outputs
Name Type Index
v 16#1600 1st RxPDO Mapping
Control Word UINT 16#6040:00
Mode0fOperation SINT 16%6060:00
TargetVelocity DINT 16%60FF:00
TargetPosition DINT 16#6074:00
Profilevelocity UDINT 16#6081:00
Profile acceleration UDINT 166083:00
Profile deceleration UDINT 16%6034:00
[]16#1601 2nd RxPDO Mapping (exchu
Control Word UINT
TargetPosition DINT
[] 16#1602 3rd RxPDO Mapping (exclu
Control Word UINT 16#6040:00
TargetVelocity DINT 16%60FF:00
[] 16#1603 4th RxPDO Mapping (exclu
Control Word UINT
TargetTorgue INT

Name Type
[v| 16£#1A00 1st TxPDO Mapping
ModeOfOperationDisplay SINT
Status Word UINT
ActualPosition DINT
Velocity actual value DINT
Position demand internal value DINT
Error code UINT
[ 16#1A01 2nd TxPDO Mapping (e
Status Word UINT
ActualPosition DINT
[] 16£#1A02 3rd TxPDO Mapping (e
Status Word UINT
ActualPosition DINT
Velodty actual value DINT
[]16#1A03 4th TxPDO Mapping (e
Status Word UINT
ActualPosition DINT
ActualTarque INT

Select an RxPDO Mapping and a TxPDO mapping.

(2) Expert Process Data

Index

16#6061:00
16#6041:00
16#6064:00
16%606C:00
16#60FC:00
16#603F:00

Gz Sync Manager: 4k Add (A Edit X Delete
Expert Process Data M Size Type oo Let
0 0 Mailbox out Index Size Name Flags  SM
S i 0 Mailbox In 1671600 250 1st D0 Mapping 3
1621601 6.0 2nd RxPDO Mapping
Startup Parameters 3 17 Inputs 16%1602 6.0 3rd RPDQ Mapping
1621603 4.0 4th REDO Mapping
EtherCAT Parameters 16#1A00 17.0 1st TXPDO Mapping 3
161801 6.0 2nd THPDO Mapping
EtherCAT 1/0 Mapping 16£1A02  10.0 3rd DO Mapping
16%1A03 8.0 4th TxPDO Mapping
Status
Information
PDO Assignment (16%1C12): o Insert [ Edt 3 Delete & Movelp & Move Down
#1600 PDO Content (1651600:
R Index Size Offs Name Tpe
602 (exduded by 16%6040:00 20 0.0 Control word UINT
[ 16#1603 (exdluded by 16%1600) 1626060:00 10 2.0 ModeOfOperation SINT
16260FF:00 40 3.0 Targetvelocty DINT
1626074:00 40 7.0 Targetfosition DINT
164608100 40 110 Profilevelocity UDINT
16%6083:00 40 15.0 Profileacceleration UDINT
1526084:00 40 180 Profiledeceleration UDINT
[ 23.0

See Axis Variable Instance Mapping_Q to add variables for output

channels.

General Sync Manager: db Add [#Edit X Delete
Expert Process Data R Size Type FRoLst
0 0 Mailbox Out Index Size Name Flags  SM
T ETE 1 0 Mailbox In 1651600 23.0 15t RXPDO Mapping 2
z 23 Outputs 1621601 6.0 2nd RXPDO Mapping
Startup Parameters 1621602 5.0 3rd RxFDO Mapping
1651603 4.0 4th RXPDO Mapping
EtherCAT Parameters 16+1A00 17.0 15t TPDO Mapping 3
1621A01 6.0 2nd DO Mapping
EtherCAT /0 Mapping 16%1A02 10.0 3rd TxPDO Mapping
162103 8.0 4th TYPDO Mapping
Status
Information
PDO Assignment (1621C13): o nsert [ Edit X Delete & MoveUp # Move Down
vl 1651400 PDO Content (1651A00):
[ 161401 (excluded by 163 Index Size Offs Namc Tpe
=] 02 (excluded by 1626061:00 10 0.0 ModeOfoperationDisplay SINT
o LY 162504100 20 10 Status Word umT
162606+:00 40 3.0 ActualPosition DINT
162606C:00 40 7.0 Velocity actusl value DINT
16260FC:00 40 110 Position demand internal value DINT
162603F:00 20 150 Error code UINT
[ 7.0 |

See Axis Variable Instance Mapping_| to add variables for input channels.

(3) Startup Parameters:
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General o Add [ Edit Delete Move Up Move Down
Expert Process Data Line Index:Subindex Name Value Bitlength
1 16#607F: 1600 Max profile velodty 200 32
Process Data 2 16#6080: 1600 Max motor speed 200 32
3 16#6085; 16500 Quick stop deceleration 200 32
Startup Parameters 4 16#060C5: 16700 Max acceleration 200 32
5 16#60C6: 16200 Max deceleration 200 32

EtherCAT Parameters

EtherCAT I/0 Mapping

Status

Information

Follow the settings in the screenshot above to set initial values for checking

motor rotation.
(4) EtherCAT I/O Mapping:

Find Filter Show all <
Variable Mapping  Channel Address Type
Ty Application.PLC_PRG. Axis_0.Mapping_Q.Obj.Controlword " Controhword = UINT
+- T Application.PLC_PRG. Axis_0.Mapping_Q.0Obj.ModeOp “ Modes of operation SoER SINT
+."g Application.PLC_PRG. Axis_0.Mapping_Q.Obj. Targetvelodty k) Target velodity SLobt DINT
+- Ty Application.PLC_PRG. Axis_0.Mapping_Q).Obj. TargetPosition ] Target Position 0p2 DINT
+- T Application.PLC_PREG. Axis_0.Mapping_Q.0bj.Profilevelodty " FProfile velocity L] UDINT
+- g Application.PLC_PRG. Axis_0.Mapping_Q.Obj.ProfileAcc i Profile acceleration 2opa UDINT
+ T Application.PLC_PRG. Axis_0.Mapping_Q.0bj.ProfileDec ] Profile deceleration SLODs UDINT
+- 4% application,PLC_PRG. Axis_0.Mapping_I. Obj ModeOpDisp " Modes of operation display IR SINT
+.- 4 Application.PLC_PRG. Axis_0.Mapping_L Obj. Statusward i Statusword ST UINT
+- % papplication.PLC_PRG. Axis_0.Mapping_LObj. PositionActual ) Position actual value IRt DINT
+. 4% application.PLC_PRG. Axis_0.Mapping_LObj. VelocityActual @ Velocity actual value =) DINT
+- 49 application.PLC_PRG. Axis_0.Mapping_T.Obj PositisnDemandInternal ] Position demand value® IS DINT

Mapping_| and Mapping_Q should be mapped to EtherCAT I/O Mapping.

5. Programming:
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1 PROGRAM FLC_FRG

L_I WE!NTEK

2 WAR
Awis 0 : weintek.RXIS REF LITE ;
Power_0 : weintek.MC Power ;
INC 0 : weintek.MC_MoveRelative ;
xEnable : BOOL ;
7 xINC Exe : BOOL ;
diDistance : DINT :
udiVel : UDINT :=
1 udifcc @ UDINT :=
11 udiDec : UDINT := 1000
12 END VAR
1
Power_0
TRUE weintek .MC Power
11 EN B ENO——
Axis 0 —SAxis Status -
®xEnable —Enable RegulatorRealState —
xEnable —RegulatorOn DriveStartRealState [
xEnable —DriwveStart Busy —
Error —
ErrorID
2
INC_0O
IRUE weintek .MC MoveRelative
11 EN - ENO——
Axiz 0 —SAxis Done
XINC_ Exe —Execute Busy [~
diDistance —Distance Active [~
udiVel —Velocity Commandiborted —
udilce —Acceleration Error —
udilDec —Deceleration ErrorID —
—_BufferMode
—_I0_Ctrl

Function blocks MC_Power & MC_MoveRelative are needed for testing motor

rotation.

Trigger “xEnable” and then trigger “xINC_Exe” to give command to the motor to
perform positioning. When MC_Power.Status = FALSE, use MC_Reset function

block to reset the motor and then trigger “xINC_Exe”.

%% Function blocks that can give command to the motor can be found in

Weintek_MC_LITE folder in Weintek Library.

For more information, please see the following user manual.

UMO018017E CODESYS Weintek Library UserManual

eng
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12 Removing Weintek Built-in CODESYS

1. Click [Tools] » [Packages Manager].
2. Find Weintek Built-in CODESYS and then click [Uninstall].

{7 Package Manager @

Currently installed packages:

Sort by: |Mame v] [ Install... ]

Mame Version Installation date Update info License info Uninstall...
9 CODESYS SoftMotion 4,1.1.0 2017/11/27 Free version 4.3.1.0 available! Mo license req
.’-'.'.| Weintek Built-in CODESYS 2018.1.24 2018/2(2 License info ne
Updates
Search updates

3. Click [Next] when seeing the window below.

& Uninstallation (===
Weintek Built-in CODESYS [2018.1.24]
Uninstallation m
WEINTEX
The package will be removed from your system. Click Next to continue.
o>
4. Removing the program.
£ Uninstallation | 3 |
Weintek Built-in CODESYS [2018.1.24]
Pleasewaitwhilethepackageisbeing uninstalled. m
WEINTEX

Initializing...
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5. Click [Finish].

5 Uninstallation IEI
Weintek Built-in CODESYS [2018.1.24] &
WEINTEK

The package has been successfully removed from your system. Click Finish to exit the
wizard.
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13 Frequently Asked Questions

13.1 Questions Related to IP Address

Q1. How to use static IP address for cMT CODESYS?

A: Please follow these steps.

1. Right-click on “Device (Weintek Built-in CODESYS)” and select [Add Device].
2. Select [Ethernet Adapter] » [Ethernet] and then select [Add Device].

[ Add Device (=3

Mame: Ethernet
Action:
@ Append device () Update device

Enter a string for & fulltext search in all devices...  Vendor: | <Al vendorss> v]

Mame Vendor Version Description
= m Fieldbusses
+- AN CANbus
+- pah EtherCAT -
= - BB Ethernet Adapter
m Ethernet 35 - Smart Software Solutions GmbH 3.5.10.0 Ethernet Link.
+- = EtherNet/TP il

3. In Device tree find Ethernet and double click it.

Devices - 0 X
=5 MTI0%0 RETN (=]
= ﬁ |Device {Weintek Builtin CODESYS)
=& PLC Logic

=L} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
= @ MainTask
& FLC PRG
[ Ethernet (Ethernet)

4. The following window opens, click [...] button.

General
Interface: E]

Status

@ Use Operating System Settings
Ethernet Device If0 Mapping Change Operating System Settings
Information IP Address 192 . 188 . 0 . 1

Subnet Mask 255 . 255 . 255 . O

Default Gateway a .0 .0 .0

5. Select “ethQ”. Please see “2.2 Creating CODESYS Project” to finish CODESYS
project settings before doing this step.
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Metwork Adapters
Interfaces:
HName Diescription IP Address
lo 127001
e 1921682110
wnetl 10.255.255.2
IP Address 192 168 . 2 119
Subnet Mask 255 355 252 .0
Deefanlt Gateway 192 188 . 1 . 254
MAC Address 00:0C 26:0FE2:3B

Lok |

6. Select [Change Operating System Settings].

General
Interface: ethO

Status

(7) Use Operating System Settings

Ethernet Device If0 Mapping @ Change Operating System Settings |

Information IP Address 192 . 168 .
subnet Mask 255 . 255 .

Default Gateway 192 . 168 .

7. Download the project to cMT CODESYS.

Q2. Why my CODESYS Gateway shows 0.0.0.0?

L_| WE!NTEK

A: When using static IP for cMT CODESYS, its IP address will be displayed as

0.0.0.0.

Q3. Can | use the same domain for cMT HMI’s LAN 1 and LAN 27
A: This is acceptable only when cMT HMI has CODESYS activated.

13.2 Questions Related to CODESYS

Q1. When the indicator of CODESYS Gateway lights up in red, how can |

connect to the device?

A: When CODESYS Gateway is not properly started or installed, its indicator will

light up in red. Please try the following 3 methods to solve this situation.
1. Click the icon of “CODESYS Gateway SysTray” in system settings and then

click [Start Gateway].
2. Add new gateway and enter HMI IP.
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Scan Metwork... || Gateway ~| Device -

| Add new gateway...

Manage gateways. ..

Configure the local Gateway...

Gateway @
Name: Gateway-2
Driver: [Tcp,r[p v]
IP-Address 192.168.2.144
Port 1217

3. Re-install CODESYS Gateway.

CODESYS V3.5 5P12 Patch 1 - InstallShield Wizard

Select Features
Select the features setup will install,

Select the features you want to install, and deselect the features you do not want to install.

Description

.[¥|CODESYS Converter CODESYS Gateway ... Next

CODESYS Gateway generation gateway
(communication layer) for

[|coDESYS OFC Server 3 TTERG

[V]CODESYS Gateway V2.3

k CODESYS Control Win W3

0.00 MB of space required on the C drive
11217.01 MB available on the C drive

[ < Back ][ Next = l[ Cancel ]

Q2. Why a triangle icon shows near Modbus_TCP_Slave device when | log in
HMI in CODESYS software?
&ﬂj Modbus_TCP_Slave (Modbus TCFP Slave)
A: This means that HMI cannot connect Modbus TCP/IP device via CODESYS.
Please check the IP settings and make sure the cable is properly connected.

13.3 Questions Related to Downloading cMT CODESYS File

Q1. How to update CODESYS firmware?

A:

There are 2 ways to update CODESYS firmware.

1. Launch Utility Manager and select cMT Series » Maintenance » CODESYS
Firmware Update. Browse for the firmware file and click [Update].
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I__|b WE!NTEK

' CODESYS Firmware Update

4] P HMIName |

HMI: cMT-E33B

Search All

Firmware : C:\codesys_20180704.229.bin

* Updating firmware will also restart HMI.

Password : 111111 [TImask

Update

2.  Enter cMT HMI’s IP address in the website browser and find [CODESYS] »

[CODESYS update] tab. Select the file and click [Update].

identity:
1 Systemi Setting
CODESYS
Network e
Date/Time Status  Projectupdate  CODESYS update
HMI Name Please select file to upload
History
Email IEFER | Application.app ("app)
Project Management SEIEREF | Application.cro (*erc)

System Password

Enhanced Security

EasyAccess 2.0

lii CODESYS

Update

Q2. How to download CODESYS project using website?

A:

1. In CODESYS software select [Online] » [Create boot application]. An *.app

file and a *.crc file will be generated.
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® Manual.project - CODESYS

File Edit WView Project Buld | Online | Debug Tools Window Help

YEE S 5 Logn Alt+F8
Logout Ctrl+Fa
Devices | Create boot application
= -@ Manual Download
=[] Device (Weintek Buitin CC Online Change
= 8l PLC Logic Source download to connected device
= O Application
m Library Manag Multiple Download. ..
PLCPRG(RE Resetuarm
o
2 Symbol Config Reset cold
= @ Task Configurz o
- @ MairTask Reset origin
& pLc_p Simulation
m Ethernet (Ethernet) Security 3
Operating Mode »

2.  Enter cMT HMI’s IP address in the website browser and find [CODESYS] »
[Project update] tab. Select the files generated in the last step and click
[Update].

CODESYS

Network “ODESYS

Date/Time Status  Projectupdate  CODESYS update

HMI Name Please select file to upload

History

Email JEIFEE | Application.app (*app}
SEIEREF | Application.cro (*erc)

Project Management

System Password

Enhanced Security
EasyAccess 2.0

lii CODESYS

Update

CODESYS® is a trademark of CODESYS GmbH.
Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their
respective companies.

This document is subject to change without prior notice.

Copyright© 2023 WEINTEK IIOT LTD. All rights reserved.
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